maya2egg error in 1.6.2

Hey all,

I’ve just installed panda 1.6.2 and attempted to import a model from Maya 2009 using the command-line “maya2egg2009.” I received this error:

Judging from the header of the window, the error is coming from maya2egg2009-wrapper.exe.

I also receive this error in earlier versions of 1.6 and whenever i run any of the maya2eggXX-wrapper executables.

Any ideas as to what I am doing wrong?

Thank you for your time,

The problem is that the libguide30.dll (or, currently, libguide40.dll) that comes in the bin directory of the Panda 1.6.2 install is older than what is referenced from Maya 2009.

The workaround: copy libguide40.dll from your Maya 2009 bin directory (e.g., C:\Program Files\Autodesk\Maya2009\bin) to your C:\Panda1_6_2\bin directory.

To do: revisit inventory within thirdparty\win-libs-vc9\opencv\bin in at least the win32 distribution and update as needed.

I had the same problem when I test exporting the maya2009. After copied the libguide.dll from maya2009/bin to panda3D-1.6.2/bin. After this, I still encountered a maya python path problem. And there’s no egg file created.

Then I found out if you use full path for the maya file, you can create a egg file. And it works. Though the maya’s python path error still exists.

When I used my compiled version of panda3D. There’s no maya python path error. The egg file works. But I need to replace the libpandaexpress.dll and libp3dtoolconfig.dd from the official version’s bin file first, or there will be errors. No idea why that happened. Maybe compiling problems?

Some update:
I compiled panda3D again using visual studio this time, the complied version doesn’t have other dll errors except the libguide40.dll. So to solve this problem:

  1. copy the libguide40.dll from maya/bin to panda3d.1.6.2/bin.
  2. when you use comand line maya2egg2009, specify the full path of the mb file.
    I tested it with some mb files, it worked. Though there’s still a python model error, you can ignore it.

I will look into the “python cann’t find maya’s python module” error.

The complaints from running The Maya 2009 egg exporter such as “Invalid Python Environment: Python is unable to find Maya’s Python modules” are fixed by having three environment variables PYTHONHOME, PYTHONPATH, MAYA_LOCATION set (at least for WIN32; different platforms require different settings for Maya 2009), along with having MAYA_LOCATION/bin set as the first directory in the PATH environment. The setup of these variables is normally done for you as part of the egger, with the latest tests and fixes in the CVS source tree at More discussion about setting the Python environment for Maya for egg exporting is on a different thread: