maya2009 lightmap export

i played around for a while, but i cant find any solution. i hope to find some help in here.

what i have i tried -> i created two uv sets. afterwards, i created a lambert shader, the color channel connected to a layerdshader (i tried the shader mode and texture mode) with two different textures in. then i connected via the uv-linking this texutres to the liked uv sets…

and the uv export failed. (no uvs are exported)

would be cool, if someone can say me what im doing wrong. i cant find any information about in the manual or in here (forum).

thanks alot…

uah, instead of the layered texture i used a layerd shader. so now it works…

If the uv isn’t linked to a texture, it won’t be exported, unless you use the option of maya2egg to export all uvs, I forgot what exactly that is. See the help yourself.

O you couldn’t find anything on the forums ?
Click my sig and scroll to bottom.

Note : I did it by script, in which I used lambert material, which is not supported by Panda’s shader generator.

yes i know, i used a lyerdshader, thats why no uv set got exported.

:smiley: i just saw your posting in the forum few minutes ago thats why its working now, you used a layerd texture instead!

but now i got a new problem, -> the exporter stops after

mental ray for Maya 10.0

ok, i could do a work around (export and import my models as fbx), but this wont be a nice solution.

the lightmap export is really a pita (pain in the a**)!

if im baking a scene and try to convert it, the converting stops?? huh?

im wondering how other peoples convert there lightmaps out of maya2009?

and yeah, you are right yo, they only way to make a nice workflow is to automate this procedere. but at first i need to know, why the converting stops?

lol now the complete converter dont work anymore! neither a primitiv cube with one uv set can be exported anymore.

oh interesting, seems maya file which i saved yesterday in maya are working to convert, but files from today cant be converted. very funny!!!

The full output of the conversion is available in the Script Editor.

im not using a exporter, i mean maya2egg2009. seems maya2egg2009 was setting anything in wrong in maya, after a couple of trys, i wasnt able to convert anything with maya2egg2009, till i reinstalled maya. or i got hacked?!

its not your fault yo!

whenever i click on autodesk icon it is saying
this application failed to start because d3dx9.dll was notfound re-installing may fix this problem plzz help and also i did not understood this step
Using the run utility and type: awkeygen.exe aw.dat

We’re not here to help you crack your software, sorry.

The error message means that you need to install DirectX 9.