Maya 2010 to .egg exporter

I was wondering if there was an exporter for the new Maya 2010 to an .egg file? I can’t find any information on it. Thank you.

not right now.

It’s probably the same as all maya. meaning if you have the sdk, you can compile it yourself. ( or try giving it someone that can compile it)

Anyone kind enough to explain how to go about compiling a maya2egg2010 exporter?


To compile the exporter you actually have to compile all of Panda from source; the Maya tools are integrated into the whole panda build system so you can’t make them without making everything else. Luckily it’s not hard (in theory).

  1. install Maya (duh).
  2. download the source code for Panda. You can get this from the downloads page but it’s probably better to check out the latest source from SVN. If you discover a bug while trying to compile, that way it can be fixed and you can get updated source easily.
  3. follow the compilation instructions, which mostly amount to running
python makepanda/ --everything

from inside the source folder.

It’ll grind away for quite a while, and at the end you’ll have a complete fresh version of Panda. The maya2egg tools are put in the built/bin directory.

I’ll just mention I haven’t tackled building the 2010 exporter seriously yet because I don’t have it on my own machine yet. One of my colleagues tried it on OSX and ran into a few problems, she’ll probably be posting more details soon.

  1. autodesk seems to have rearranged the maya/ folder, so include/ is now in devkit/, while all the .dylibs are in the oddly named “Mac OS” folder inside the I think this creates a huge problem for makepanda which assumes that both include/ and lib/ are in the same place as part of an SDK. the quick fix is to copy lib/ into devkit/ …

  2. once it builds, if you want to test before installing, you do need to set your PYTHONPATH and DYLD_LIBRARY_PATH. Note that on OSX it’s DYLD_LIBRARY_PATH, not LD_LIBRARY_PATH.

  3. currently stuck on a python compatibility problem between the Maya version and the OSX version which isn’t too much of a surprise but I don’t know exactly how to fix.

Send me the include and lib dirs (without libfbxfilesdk) and I’ll include support for Maya 2010 in the official release.

I tried compiling the exporter, and it gave me an error complaining about 64bit (which is the version of Maya I installed)… I’m gonna assume that means I’d have to install the 32 bit version of maya?

Rdb - I was going to try sending you the two folders, but it was about 50 megs zipped and I didn’t see anything named libfbxfilesdk so I wasn’t even sure if those two folders were indeed the correct two anymore.

Ah, then I was wrong about fbxfilesdk. It’s quite big indeed - the lib and include dirs.

Was I correct that the 32 bit version of maya is needed to compile the exporter though?

Nevermind, installed 32 bit and it compiled just fine.

Now to test them! (/ kicks artist)

Panda (as of 1.7 I think) will load a .dae file exported from Maya no problem. No need to convert to .egg

Aloha !

I was wondering if they were some news about this feature ?
Did anyone know ?
'Cause I’m actually using Maya 2010 and I need to use a sub-software to export from Maya 2010 to EGG …