matplotlib: module missing

Hi to everybody :slight_smile:, i’m new on this forum and i apologize for my english that isn’t that great.
I have a problem to import matplotlib into .p3d file, when i use packp3d command i get this warning:

There are some missing modules: [‘FCNTL’, ‘Image’, ‘System’, ‘System.IO.Ports’, ‘TERMIOS’, ‘bluetooth’, ‘clr’, ‘matplotlib.patches’, ‘matplotlib.path’, ‘matplotlib.pylab’, ‘matplotlib.pyplot’, ‘panda3d.core’]

and obviously if i try to lunch my .p3d file i got an error: ImportError: No module named matplotlib.path

I’ve tried to use -p option to indicate where the matplotlibs are and to copy the missing modules into my project directory but it doesn’t works…

I’ve tried to create a pdef file too, but the problem is the same…


This is a bit of a shot in the dark, but are you including the “morepy” package (via the “-r” parameter) when you run packp3d?

Hi, yes,but it doesn’t solve my problem…


System, System.IO.Ports and clr (Common Language Runtime) are C# namespaces. Are you mixing up with IronPython for some reason?

sorry but i don’t know…I have not developed this project, i just completed some features and graphics…i’m new in python and Panda3d so i can’t say you if i use ironPython or not…there is a way to know if i use it?


i discovered that System, System.IO.Ports and clr are in missing modules list only if i set -p option to solve ‘serial’ missing module…

Hi to everybody :slight_smile:In these days i solved some problems of my project and now the only missing modules are ones matplotlib…any new ideas to solve this problem?

[UPDATE] Hi, there is someone that could help me? i discovered that if i copy the entire matplotlib folder into my project folder i have this error while create p3d file with packp3d:

LookupError: no codec search function registered: can’t find encoding
:task(error): Exception occured in PythonTask Messenger-default