Mac Os X: Issue setting python path

I am having an issue with what I believe is multiple instances of python.

I have successfully installed the Panda3d 1.6.2 distribution, but I am unable to start. From the terminal, entering the command ‘ppython’ returns:

-bash: ppython: command not found

This occurs no matter what directory I am in. I have found other threads and documentation dealing with this issue and some recommended not using ppython, but using python instead. Entering ‘python’ enters me into the python editor.

When attempting to load samples, or by following the startup guide in the manual using ‘python’, the response is this:

Traceback (most recent call last):
File “”, line 1, in
import direct.directbase.DirectStart
ImportError: No module named direct.directbase.DirectStart

In researching the issue involving direct.directbase.DirectStart I have found that this issue points to the python path being incorrect and pointing to an improper python distribution. I have tried entering the startup command by pointing it directly to the python distribution I want to use, with no effect, as well as changing the python path in .bash_profile, also with no effect.

Any advice on how to get Panda3d up and running?

My system specs:

MacBook running Mac OS X 10.5.6
Panda3d 1.6.2
MacPython 2.5, Python 2.6

Thank you for your time,


Okay, the problem is your extra versions of Python. You have three versions installed: the 2.5 build from Apple, and the two you’ve mentioned.

Panda is compiled against the build from Apple. You need to run specifically that one before anything will work. So, try to use /usr/bin/python directly.

ppython was supposed to be a convenient symlink to /usr/bin/python - but apparently it didn’t get shipped into the .dmg, for some

Please pardon what may seem like a question with an obvious answer. Should I delete the other versions of python? If not, how do I specify that I want to use the Apple Version of python?

I tried this at the command prompt:


That still returns:

File “”, line 1, in
import direct.directbase.DirectStart
ImportError: No module named direct.directbase.DirectStart

Same as just using ‘python’.



Wait a sec, you did double-click the profilepaths.command script in the Panda3D dmg, so that panda path information got written to ~/.bash_profile, right?

I had not done that, until now. When I do double click it, it says panda3d is already configured. Trying python, python2.5 and python2.6 all fail to work.

I went on to remove the .bash_profile file into another directory and used the path script again, this made a new .bash_profile file but the results were the same.

Any more advice on getting Panda3d up and running? Should I consider entirely removing Panda3d and reinstalling?


I uninstalled everything and reinstalled, actually following the directions this time. Worked like a charm.

Thanks for the help!


Hello Drew,

I think we were facing more or less the same issue and I’m thinking of doing the same as you did: removing everything and reinstalling.

My question is: What did you remove exactly ?
Only python ? Isn’t there a version we must keep ?
Or everything and reinstalled panda, python and and CG from scratch ?

That’s OK Drew… I found an alternative!