Mac OS - won't run at all

Hi, I’m having some problems getting Panda3D to run at all on my machine:

$ ppython /Developer/Examples/Panda3D/Asteroids/ 
DirectStart: Starting the game.
Traceback (most recent call last):
  File "/Developer/Examples/Panda3D/Asteroids/", line 13, in <module>
    import direct.directbase.DirectStart
  File "dstroot/pythoncode/Developer/Panda3D/lib/direct/directbase/", line 3, in <module>
  File "dstroot/pythoncode/Developer/Panda3D/lib/direct/showbase/", line 10, in <module>
  File "/Developer/Panda3D/lib/pandac/", line 8, in <module>
    from libpandaModules import *
  File "/Developer/Panda3D/lib/pandac/", line 2, in <module>
  File "/Developer/Panda3D/lib/pandac/", line 79, in Dtool_PreloadDLL
    imp.load_dynamic(module, pathname)
ImportError: dlopen(/Developer/Panda3D/lib/libpanda.dylib, 2): Library not loaded: @executable_path/../Frameworks/Cg.framework/Cg
  Referenced from: /Developer/Panda3D/lib/libpanda.dylib
  Reason: image not found

I’ve read about similar problems on Mac OS X via searching, but most of those appear to have been solved by switching from ‘python’ to ‘ppython’, something which is not working for me (as per above).

I’ve tried both 1.7.2 and 1.8. Any ideas?

Hi, welcome to the forums! There is your error here, they suggest installing the NVIDIA Cg Toolkit. Are you sure that you have correctly installed it?

Ah, of course. Thank you!