mac issue: not relocatable due to Config.prc

I tried installing Panda3D 1.6.2 to ~/programs/ instead of /Applications/, but when I tried running the sample programs, it would not run. After some tinkering, I’d get it to run iff I copied my Config.prc to /Applications/Panda3D/1.6.2/etc. Without looking at the source, it looks like the config file is hard coded with an absolute path.

Could the Config.prc file be referenced with a relative (to the bundle) path?
I’m not a Mac dev, so I don’t know the ‘proper’ way of doing it. I’d assume there’s an ‘official’ method to source files based on the package location, but that’s an assumption.

On a related note, if a full port was to be made, I suspect the config file would end up as a plist somewhere (/Library? ~/Library?). But again, not a mac dev (yet).

Only things I could find in a quick search are:


The Config.prc file is supposed to be located relative to whatever directory it loads libp3dtool.dylib out of, or failing that, relative to python. Perhaps it was failing to identify libp3dtool, and settling on /Applications as the home of python.


In 1.6.x and before, Panda was unable to do this on OSX - so I had to hardcode the path. In the current CVS version of Panda I fixed this, so this should work correctly.

Mooshu, if it’s an urgent problem, I could make you a build of the CVS for OSX. Email me.

Thank you Pro-rsoft, but I’m good. I just installed in /Applications and I’m learning (Panda3D / Python) now. Just wanted to drop the bug report, but guess it was unnecessary in this case :slight_smile:

Thanks for the Mac port!