Mac 10.9 window focus issue running the examples

Hi … apologies if this has been answered already on the forums.

I’ve just installed Panda3D 1.8.1 and XQuartz 2.7.5 on a Mac 10.9 Maverick. The examples run up fine, but I am not able to get window focus on the windows, and therefore cannot enter key commands etc. Has anyone had a similar issue to this before, and is there a simple resolution? The examples are being run with ppython.

Thanks for any help.

I’m afraid that 1.8.1 uses Carbon, which is an API that Apple has deprecated and no longer supports. You will have to use a more recent build, for instance this experimental build (which is quite old now to be honest):
It’s 64-bits and compiled against Python 2.7.

Thanks for the reply and information - much appreciated. The more recent build is working for me.

I get an similar error:

What happens is that the Installer erros out, saying that I have to contact the manufacturer. However, I can see the Developer/Panda3D and /Tools folders. I haven’t tried any samples or my project yet, installing XQuartz now.

Panda3D SDK: Panda3D-2013.08.22-94 (devel)
CustoMac OS X.9 “Mavericks”

Alright, after installing XQuartz 2.7.5 and a reboot I tried to fire up my project, but to no avail:

That’s a freetype symbol. Can you use “otool -L” on libpanda.dylib to find out which freetype library it links with, and see if you have multiple versions of that library on your system?

Hi rdb,
I tried your build. The installation was fine but when i run an example i’m getting this error:


DirectStart: Starting the game.
Traceback (most recent call last):
  File "", line 7, in <module>
    import direct.directbase.DirectStart
  File "/Developer/Panda3D/lib/direct/directbase/", line 3, in <module>
    from direct.showbase import ShowBase
  File "/Developer/Panda3D/lib/direct/showbase/", line 10, in <module>
    from pandac.PandaModules import *
  File "/Developer/Panda3D/lib/pandac/", line 2, in <module>
    from libpandaexpressModules import *
  File "/Developer/Panda3D/lib/pandac/", line 1, in <module>
    from extension_native_helpers import *
  File "/Developer/Panda3D/lib/pandac/", line 81, in <module>
  File "/Developer/Panda3D/lib/pandac/", line 79, in Dtool_PreloadDLL
    imp.load_dynamic(module, pathname)
ImportError: dlopen(/Developer/Panda3D/lib/libpandaexpress.dylib, 2): no suitable image found.  Did find:
	/Developer/Panda3D/lib/libpandaexpress.dylib: mach-o, but wrong architecture

I’m using OS X 10.9 Mavericks, 64 bits processor.


I’m guessing that there’s a conflicting build of Panda3D installed. Delete /Developer/Tools/Panda3D and /Developer/Panda3D and try again.

Thanks rdb.
I tried that without luck.
After that i deleted the following files/directories:


and then i installed your panda build 1.9 but i’m getting the same error running different examples.
Is there any other thing i can try?

Thanks again for your help.

Perhaps you’re running the wrong Python build? My build is compiled against 64-bits Python 2.7. Try running “python2.7” and disable any versioner 32bit preference setting.

Great rdb!
I found i had a preference setting to run python in 32bits. I changed it and it works.
This build of Panda i’m using is a recent snapshot?


Not very recent, no, sorry.

Sorry rdb but running the Media Player example i found another problem:


DirectStart: Starting the game.
Known pipe types:
(all display modules loaded.)
Traceback (most recent call last):
  File "", line 78, in <module>
    w = World()
  File "", line 33, in __init__
    assert, "Failed to load video!"
AssertionError: Failed to load video!

Is there anything i can do to reproduce this type of avi files?


The experimental build I made does not contain ffmpeg support, sorry.

Ok, thanks anyway.

Hi, I have a similar issue,
I installed Panda3D (the 1.9 version) and also went ahead and installed XQuartz 2.7.5.

I get this error when trying to run one of the samples 1.9:

From the looks of it ( i am no expert) it has something to do with Cg.framework. I googled that and it has something to do with NVIDIA graphics card. However i am on a new MbPro "15 retina. And I am pretty sure it doesn’t have the NVIDIA graphics card, it has the Intel Iris pro. How can I fix this? Thanks !

Here is my specs:

  • OS : Mac os x marvericks 10.9
  • GPU: Intel Iris pro
    -Python version : 2.7.5
    -XQuarts 2.7.5.

It’s not a similar error at all. You simply need to install the NVIDIA Cg Toolkit, as stated on the download page and on the Getting Started page. You can download it from the NVIDIA Cg Toolkit website.

The NVIDIA Cg Toolkit has nothing to do with NVIDIA cards. The toolkit works on all cards.

Thanks rdb,
You are right it is not similar. This is one of the few topics/boards on the matter though. I went ahead ant installed the latest NVIDIA cg toolkit and now the sample program does start running, and a white window appears but suddenly it crashes and gives me this message:

Weird. Seems to be an issue in Tcl. Also, make sure that you’re running the right version of Python - 64-bits python2.7 if you’re using the build I linked.

Hm, says I have to download and install XCode to use otool. Don’t really want to do that.
Interestingly, the error prompt says: Load XCode, Cancel and Install Command Line Tools. Would the latter only install a certain toolset, without installing XCode in full?