libp3framework.dll is missing from your computer

i am using Visual C++ 2010 Express, just came off of Ogre because it was too complicated, and I have run into this little problem.

“The program can’t start because libp3framework.dll is missing from your computer. Try reinstalling the program to fix this problem.”

This error came up after I tried to put in the enviroment. The first Panda3D tutorial, making the window appear, worked just fine for me. I have reinstalled Panda3D like it suggested but it still fails.

I just went through my computer, I have the .dll file that it says my computer doesn’t have. Any suggestions on how to get my compiler to read it?

You cannot use Visual C++ 2010, you must use 2008 with the downloadable SDK build of Panda3D.

I just had the same problem with visual studio 2008, and i do include the directory of libp3framework.dll in tools->options->vc++directories: C:\Panda3D-1.7.2\bin in directories for executables.

This directory needs to be on your PATH variable as well. I’m surprised it isn’t already, though, since the Panda3D installer is supposed to put it there; but maybe you have overridden this?

Still, if you are looking for a less-complex graphics engine solution, may I suggest considering the Python interface? Any C+±based engine is going to be big and complicated to use, and it will take a while to learn. On the other hand, the Python interface tends to be easier to use out-of-the-box, and development in Python is much faster than in C++. In fact, I’d say that for a given amount of development effort, you can do a much better game in Python than you can in C++, because development is so much faster.

Of course, the language you choose to develop in is totally up to you. I only bring this up because you mentioned wanting to avoid the complexity of Ogre, another C+±based engine.


My PATH variable? I don’t really understand what you are referring to, sorry. Do you mean that I have to put the dll in my project folder or something like that?

I have made a regular installation of panda, nothing overridden as far as I know…

Thanks anyway for the effort to help :slight_smile:.

Make sure your PATH variable, listed in your system Environment, includes c:\Panda3D-1.7.2\bin along with whatever folder names it already includes.


You mean any of this?
(ProjectName), (ProjectDir), $(SolutionDir)

I tried to write it like this instead:

And i placed the missing dll (libp3framework.dll) in
C:\Users\User\Documents\Visual Studio 2008\Projects\Panda3D_Framework\bin
But it still generates the same error.

Can you explain what you mean by path variable a little more in detail? because i’m still not sure what that is… … ows-7.aspx