on a fresh install of ubuntu / panda3d

Hello everyone. I have the new 10.04 ubuntu (lucid). I installed the panda3d_1.7.0-ubuntulucid_i386.deb and now I am having trouble. I have been researching the issues I have had and fixed most of them (for instance, trying to install from the karmic deb instead of lucid, which gave me the error: Dependency is not satisfiable: libcv1).

Now, when I navigate to /usr/share/panda3d/samples/Asteroids and type the command “python” I get the error:

ImportError: cannot open shared object file: No such file or directory

Now, searching, I came up with these posts:

On Jan 16, 2010, treeform posted that he was getting the same error on ubuntu 9.10 64 bit.

On Jan 16, 2010, rdb posted in response to treeform that “the daily package doesn’t list dependencies. In this case, you’re missing the packages nvidia-cg-toolkit and ffmpeg.”

So, based on this, I have installed ffmpeg with synaptic packet manager. The nvidia I already had installed.

Now, since I can find no other information on this error, I am hoping that someone here can help me.

For more information, I have tried a fresh build of Panda 3d, but that gave me nothing but errors.

On the step (python makepanda/, then type makepanda --everything), nothing would happen on the second part. Typing the python makepanda/ would give me a list of commands, but I could never type them.

If I tried to do the python makepanda/ (forget exact filename) I would get a long list of libs and such that it could not find, and then it would terminate.

Thus, I gave up on making / building, and simply used the deb file.

Again, hopefully knows what is and how to fix it.

Further, in Synaptic Packet Manager, when searching for libC, I see there are files like libCgraph.so4… would one of these work even though they aren’t the same name? is part of the nVidia Cg toolkit. Are you absolutely sure you have that package already installed?


According to SPM, “nvidia-cg-toolkit” (version 2.1.0017.deb1+nm) is currently installed and is the latest version. Description is NVIDIA Cg Toolkit Installer.

Do you think reinstalling would help? Since all feedback thus far is that it is nvidia that is the problem, and yet it is installed.

Hmm. From

So, it seems the package is a little misleading–installing the package only gets you the installer. Try running the program nvidia-cg-toolkit-installer to see whether it gives you a


Hum, I think that it should be automatically run in the postinst of the .deb file.

Ok, following this, I tried to install using that command. Here is the output:

bob@bob-laptop:~/Desktop$ sudo nvidia-cg-toolkit-installer --install

Downloading (Bad hostname ‘’)
Failed to download NVIDIA Cg Toolkit.

Now, this may be because I have no dedicated internet. I live out in the woods, and my only source of internet is through my google droid phone, using a program called “Proxoid”. I set up the port forwarding correctly for the internet to work, and believe I have the localhost http port 8080 set up system wide as synaptic package manager is able to download and update correctly. So, the installer might be failing I think because it isn’t trying to connect correctly to the internet?

I decided to try to skip this and simply copied the internet address and downloaded the actual file. It was an archive and I extracted the usr folder and all of its subfolders out. Now, when I try to merge the downloaded usr folder with mine (to add in the child folders that are for NVIDIA) it say’s I am not able to and the operating system itself appears to be forbiden me from adding files to usr. Now, this is most likely for my own safety so I don’t mess up the OS by being new and stupid (I am new, but I am not stupid =P).

So, any suggestions?

I am going to try to use a dedicated internet with rj45 cat 5 cable later this week, but hoping I can get it fixed relatively easily before I try that.

i’d recommend you get dedicated connection.
although you can get enough system privilidges to install stuff manually i highly recommend against it. cause if you do so. the package management software has no idea that you did it, so it usualy ends up in a single, big mess sooner or later. it’s totaly not worth it. let the software deal with it, it knows what’s best for your system.

Thank you everyone. Got hooked up to a wired network and got the program installed without incident. The key was to indeed do the “nvidia-cg-toolkit-installer --install” on wired network. For some reason, it wasn’t able to go through the port forwarding.

Panda now works quite well =D

Again, ty.

this info would go well at the bottom of … D_in_Linux, where it lists various errors. Thanks

I believe the issue is already fixed in Ubuntu Maverick.