kindof "completed" compiling Panda3D1.6.2 but not


I’m trying to compile Panda from 1.6.2 source using VS2008 on my Vista64 (I’m doing 32bit build), and it looks like the Panda itself is doing fine (I can start all samples code)

The problem is, I cannot complete “maxegg2009” module, which i want to use it on my 3dsMax2009 :frowning:

Here is the error I have from Max2009,

“R6034: 3dsmax loads C Runtime Model incorrectly,
Error 1114: maxegg2009.dlo intialize fail”

I think I have to modify a few things in “” to make panda look at MaxSDK at the correct place

line 40: (“MAX2009”, “SOFTWARE\Autodesk\3DSMAX\11.0\MAX-1:409”, “Installdir”, “…\3ds Max 2009 SDK\maxsdk\include\CS”),

once it is complied I have the link error where I also fix this command, but I relink it from VScommand line! :frowning:

link /nologo /NOD:MFC80.LIB /NOD:MFC90.LIB /NOD:LIBCI.LIB /NOD:MSVCRTD.LIB /DEBUG /nod:libc /nod:libcmtd /nod:atlthunk /DLL /MAP:NUL /FIXED:NO /OPT:REF /STACK:4194304 /INCREMENTAL:NO /OUT:built/plugins/maxegg2009.dlo /LIBPATH:“thirdparty/win-python/libs” built/tmp/maxegg2009_composite1.obj built/tmp/maxEgg.obj /DEF:“pandatool/src/maxegg/maxEgg.def” built/lib/libeggbase.lib built/lib/libprogbase.lib built/lib/libconverter.lib built/lib/libpandatoolbase.lib built/lib/libpandaegg.lib built/lib/libpanda.lib built/lib/libpandaexpress.lib built/lib/libp3dtool.lib built/lib/libp3dtoolconfig.lib built/lib/libp3pystub.lib comctl32.lib comdlg32.lib user32.lib “G:\Program Files (x86)\Autodesk\3ds Max 2009…\3ds Max 2009 SDK\maxsdk/lib/core.lib” “G:\Program Files (x86)\Autodesk\3ds Max 2009…\3ds Max 2009 SDK\maxsdk/lib/edmodel.lib” “G:\Program Files (x86)\Autodesk\3ds Max 2009…\3ds Max 2009 SDK\maxsdk/lib/gfx.lib” “G:\Program Files (x86)\Autodesk\3ds Max 2009…\3ds Max 2009 SDK\maxsdk/lib/geom.lib” “G:\Program Files (x86)\Autodesk\3ds Max 2009…\3ds Max 2009 SDK\maxsdk/lib/mesh.lib” “G:\Program Files (x86)\Autodesk\3ds Max 2009…\3ds Max 2009 SDK\maxsdk/lib/maxutil.lib” “G:\Program Files (x86)\Autodesk\3ds Max 2009…\3ds Max 2009 SDK\maxsdk/lib/paramblk2.lib”

I have to put " for all this space-included path manually
“G:\Program Files (x86)\Autodesk\3ds Max 2009…\3ds Max 2009 SDK\maxsdk/lib/geom.lib”

then it produces “maxegg2009.dlo” for me, I copy it to the Max2009/Plugin directory and then the errors appear

I also put this into my windows path, to solve Error 62:intialize error

Please help! thanks in advance

I don’t think you can use 32-bits modules against the 64-bits version of 3dsmax. Are you sure you’re running the 32-bits version of 3dsmax?

thx for your response,

I’m 100% positive that I’m running the 32bit version of 3dsmax2009
(The one located in x86 Program File Dir)

Additional Info: because I think I run the linker manually from the commandline, then after I put .dlo file in Max/Plugin I also copy all the maxegg2009.* (lib, manifest, …) into debug/bin
Still doesn’t help

Here’s also another question, are there any option to build only the thirdparty plugins without rebuilding everything?
After I completed building Panda, I want to rebuild only Max (which it is the failed before)
I tried “–nothing --use-max2009” (replace in the VS NMake proj), it seems like it does nothing but error :frowning:

Actually, if you run makepanda, it will only rebuild what has changed (or what has not been built yet). This only works if you do not change the commandline options, however. Because you have changed the options now, you forced a full rebuild. :slight_smile:

is that just the makepanda.bat? or any changes that make to, force it to do a full rebuild too?

anything can prevent this?, something like a separate .sln just for the pandatool?

thx again for your help :smiley:
ps: i still don’t know about that “incorrect C runtime” but one of my teammate said might because Max2009 doesn’t like the plugin made from VS2008,
i might have to try VS2005 and see how it goes

Nah, VS2005 won’t work, probably.

VS2005 is worse, lots of LIBC error :frowning:

any idea how can I get maxegg2009 to compile and working?

well, I decided to fall back to 1.5.4 and it worked!
exactly the same procedure which I have problem before