Issues importing Collada files from Blender

I am making a game and have been using models I made in Blender and exported as Collada files. This has been working fine, but I recently came to a problem. There is one model that whenever I run the project and it gets loaded in for the first time, an error message appears:

AssertionError: cdata->_primitive_type == PT_none || cdata->_primitive_type == primitive->get_primitive_type() at line 369 of c:\buildslave\sdk-windows-amd64\build\panda\src\gobj\geom.cxx

I have no clue what this means and like I said, I haven’t had any problems with this before. Please help if possible.

Some steps you can do to find whats is happening:

Check the model before rendering using analyze() to have more information about what is happening with it.

Open it with pview to ensure it can be rendered alone.

Verify in Blender if UV mapping is ok.

Try to convert it to EGG (and/or BAM) and see debug messages.

…hope it helps.

Thank you for the help, I believe I have figured it out. It seems there was some loose geometry in the model, there were 2 random unused edges that I had to delete. After that it worked fine.

Which version of Panda is this? I recall a similar bug was fixed recently.