Installing wxpython

Uploaded with

Is it just the scripts folder that should be there or all of the installation? So I chose to install it in the site-packages folder, then it had installed the scripts folder in a newly made folder called ‘Put a directory on PYTHONPATH here’ so I copied the files in it to the site-packages folder as well.

Hmm. Haver I gone horribly wrong. The Panda samples work, just not the wx stuff.

“Put a directory on PYTHONPATH here” is not a directory name to use! It’s an instruction for you.

Python needs to find libraries you import. For that it uses a list of Paths (directories). The environment variable where all these paths are stored is called PYTHONPATH.

By default the site-packages should already be on the PYTHONPATH. On your screenshot everything looks alright. Also you need all the files, not only the scripts directory. Especially the wx.pth file contains further instructions for Python to import the rest of wx. Open the file with a simple text editor like notepad (not Word!) and check if the contents are okay.

Also it might help if you post the error message from Panda. Maybe it isn’t related to a missing wx package at all.

It actually automatic creates that folder whatever I do about either browsing to or typing in the site packages path for installation.
The wx.pth file simply reads the version. I found a readme which directs you to a wiki page relatively explaining the issue for multiple installations.

Presumably I need to have the installation look as it does in the site packages folde, the edit the wx.pth to state it needs to import wx?

Presumably when wx is called upon, it’s going to read the wx.pth file?
So the wx.pth file needs to read literally:

Import wx-2.9.4-msw (2.9.4)
Import wx

Instead of


And it will find it then???
I think the problem is along these lines.

I’m afraid I haven’t run wx from Panda yet, just the file included in the scene editor, which is where the problem then surfaces in wingide reporting wx is not installed.

No, your wx.pth file looks correct. Don’t change it. I think the failure here might be a second python installation. Did you install Python as standalone? People often do this mistake. Panda ships with its own Python version.

I don’t really know what was messed up for you, sorry. Usually when leaving all default settings, things run smoothly with wx-python.

Lol. I couldn’t wait.
It then reports an error ‘cannot import name publisher’ doesn’t that suggest I’m further own the right path?
would the publisher error be a factor of not having the scene editor I’m using on the pythonpath

Anyway, on installation, the installer states that it can’t find a copy if python 2.7?? Well the panda3d sample programs run, so… Then you install wx.
I had checked my program list, but have found that there is a separate 2.7 folder… Which I’ve manually deleted…

So it may now be right just a similar issue with the editor.

There’s a bug in the 1.8.0 installer that causes Panda’s installer not to write its Python installation to registry. Try using the latest devel build instead.

Ah thanks. I’m going to double check if the publisher error is what I think it might be but I’ll definitely install the dev build then.

I’d like that to work.

HI James,

As rdb mentioned, you’ll have trouble installing wx for Panda 1.8.0. If you want to use it and not the latest dev build you can try the following:

  • Install Panda 1.8
  • Install default Python 2.7 interpreter
  • Install wx for default Python 2.7
  • Create the file

with the following contents:


This will tell Panda’s python interpreter to look in the default interpreter’s site-packages directory for the wx installation.

Thanks, it certainly installs correctly and compiles with the dev version. That 1.8 should come with a warning…