installing on windows

I have searched the forums but I couldn’t find anything on compiling applications under windows.
My error is, panda installed just fine and I created a path file so I could use my own python 2.5 installation.
When I try and compile the tutorial from the docs I get this:

Warning (from warnings module):
  File "C:\Panda3D-1.5.0\pandac\", line 13
    raise "Cannot find libpandaexpress.dll"
DeprecationWarning: raising a string exception is deprecated

Traceback (most recent call last):
  File "C:\Python25\Games\Panda\", line 1, in <module>
    import direct.directbase.DirectStart
  File "C:\Panda3D-1.5.0\direct\src\directbase\", line 3, in <module>
    from direct.showbase import ShowBase
  File "C:\Panda3D-1.5.0\direct\src\showbase\", line 10, in <module>
    from pandac.PandaModules import *
  File "C:\Panda3D-1.5.0\pandac\", line 1, in <module>
    from libpandaexpressModules import *
  File "C:\Panda3D-1.5.0\pandac\", line 1, in <module>
    from extension_native_helpers import *
  File "C:\Panda3D-1.5.0\pandac\", line 13, in <module>
    raise "Cannot find libpandaexpress.dll"
Cannot find libpandaexpress.dll

Anyone have any idea what’s going on?
Panda looks great but won’t be much use if it’s as easy to install as python ogre.

EDIT: I have been messing around with this for 3 hours now and have also tried older versions of both panda and python but nothing has worked.
I really tried to get it working before I asked here.

EDIT 2: After poking around for another hour I discovered that I also had to include the lib folder in my path.
Everything works now.

I take it you want to compile your own Panda program written in C++? Or, are you trying to compile Panda yourself? If the latter, you do not need to do so on windows. The download page has windows binaries.

It sounds like a panda path problem. Does your panda.pth file have a panda/bin entry?

Yeah I figured it out.
I hadn’t set the path to include the bin folder.

I am trying the same thing & I get the same error message.

I have the following in ‘panda.pth’ in the directory where my copy of (Enthought) python starts:

C:\Program Files\Panda3D-1.5.0;C:\Program Files\Panda3D-1.5.0\bin

(Also, these folders are on the system path)

If I copy the DLLs into Enthought Python’s DLL folder, it works. So there’s a workaround, but I figure this is going to be a mess later, best if I can figure out how to set the path properly now.

… help …??

I’m not sure you can use a semicolon in a PTH file. Try one path per line, like the PTH file include with Panda3D.

d’oh! Thanks … it’s working now.