Installing chicken?

Hit there. This is my first post here.

I am trying to setup the latest Chicken release, but whenever I try to run the script in Blender, I get an error saying that it cannot locate Does anyone know why this is happening? I have tried just about everything I can think of.


Did you extract all the files and directories in the zip file into the “scripts” dir of blender?

Not only HeIsTheGuy got that problem.

I got it as well. Everything installed in Script directory; re-evaluated scripts

You must specify the egg file to read on the command line.

egg2bam [opts] input.egg output.bam
egg2bam [opts] -o output.bam input.egg

Traceback |most recent call last|:
File “”, line 1, in
File “C:Programme\Blender Foundation\Blender\Scrips\”, line 1536, in
Blender.Run<oos.path.join<Blender.Get<‘datadir’> ‘chicken/’>

AttributeError: no such file or Blender text

Yes I did that, and I get that exact same error.

But I tried the first version of chicken availabe to download, and it works fine. So I’ll just stick with that one I guess.

That version is old and doesn’t support a lot of things. The reason that it does work is that it doesn’t have additional Python files.

Just to second pro-rsoft, that error is entirely consistent with missing files. In fact, what is interesting is it checks for the interface code first, which is in bpymodules, and then checks, and fails in your case, for the configuration gui, which is in the bpydata directory. So, have you two by any chance decompressed bpymodules but not bothered to decompress bpydata on the assumption that it only contained the manual by any chance? Alternatively, if you are running Linux there is always the chance of screwy permissions on an existing bpydata breaking the decompression - what OS’s are you running?

I’m on windows, and what do you mean by decompress?

Decompress is the technically correct term for unzipping files.

Oh well then yes I believe I did that.

Well, that error is basically saying that the file ‘bpydata/chicken/’ does not exist in the scripts directory. If that file actually does exist then something is very screwy.

Well I made sure that it was there, so I don’t know… - that thread has the solution to what I think is the problem being reported in this thread.