Installation on Mac OS X: pointer/suggestion


#1

I just installed Panda3D 1.8.1 on my MacBook Pro, running Mac OS X 10.9.5. When I tried to run the example programs, I got the error message mentioned on the “Getting Started on OSX” page regarding the Cg toolkit. Obviously I found that page, but since the Cg framework was from NVIDIA, I thought it wouldn’t be applicable; my graphics adapter is the Intel HD Graphics 4000. Yet there was no comment here connecting the two. I was puzzled and frustrated. I was about to post a question asking what to do, but I thought I’d simply install the Cg toolkit from NVIDIA’s site and give it a try, figuring it wouldn’t hurt, at least not much.

I was surprised when that worked. Either that toolkit doesn’t talk directly to hardware, or the Intel hardware presents the same interface that the NVIDIA adapters do.

Regardless, it worked. My suggestions:

  1. If you’re trying to get Panda3D running with a similar setup (which seems not too unlikely, since I believe most of the MacBooks are using Intel graphics hardware), just go ahead and install the toolkit.
  2. Panda3D people: you might add a note on the “Getting Started on OSX” page to this effect, so that others don’t experience the same puzzlement and lost time that I did.

Onward and upward! I plan to use Panda3D as a basis for tutoring on 3D graphics programming, so having it running is a Real Good Thing :slight_smile:


#2

Great, welcome to Panda3D! :slight_smile: Too bad you got a bit of a rough start. :frowning:

To clarify the confusion: the NVIDIA Cg Toolkit has nothing to do with NVIDIA graphics adapters. They’re two completely different products that both happen to be made by NVIDIA. The Cg Toolkit is a piece of software that compiles files written in the Cg shading language to a target driver format, which can be a vendor-neutral format like ARB programs or GLSL, and will work on any graphics hardware, be it Intel, NVIDIA or AMD.


#3

Thanks for the clarification! I’ve always been working at a higher level of abstraction, and had no idea that NVIDIA had produced anything that wasn’t intrinsically tied to their hardware.

Their page for the Cg toolkit was very clear that they’ve left that behind, and while it’s still available and obviously functional, they recommend that any future development use GLSL or HLSL. Do you know if Panda3D is headed in that direction?


#4

Yes, we are. We have good support for GLSL nowadays, and in the upcoming 1.9 release we’ve still improved the GLSL support by a lot. The main reason we still rely on Cg is because our shader generator is written to produce Cg code. Replacing the shader generator with something that will work with GLSL directly is something that’s high on the list of priorities.


#5

I installed panda on a OS X 10.10.5 system. It crashes on launch. Found this thread and tried installing the NVIDIA CG tool.Still crashes on launch. The site’s documentation section/manual omits a heading for “installing on OS X.” Any suggestions?


#6

Which version of Panda3D are you trying to install? You should use the latest 1.9.1 SDK release from the download page.

Do you have more information about the crash, such as a crash report, or a command-line output?


#7

Latest release. Downloaded 2 days ago.
I don’t have access to the machine in question at the moment to check logs.


#8

Well, I’m not sure what I can say. Since it works for other people, I’d need more information to make any kind of guess as to the problem. We don’t know which command you tried to run, what the command-line output was, if there was a crash log generated by Apple…


#9

OK. I have access this morning.
Double click application bundle.
One line of output in in the system log:
Dec 7 08:50:23 phd-m06 com.apple.xpc.launchd[1] (org.panda3d.runtime.panda3d_mac.69612[45923]): Service exited with abnormal code: 1

Not Finding anything related in ~/Library/Logs or /Library/Logs


#10

Panda3D is not a program. What you installed must have been the Panda3D Runtime, which is only useful for running packaged Panda3D programs (.p3d archives, or in the web browser).

If you mean to develop with Panda3D, you need to install the SDK, which ships with a bunch of Python libraries that you can use to develop a 3-D application.


#11

Thanks. As it turns out, the user wasn’t after Panda 3D after all anyway.