Installation on Debian

Hi, guys!

I’m trying to install panda3d on my debian wheezy (32-bit). I’va downloaded the installer for i386 architecture from this page.

I ran this command:

sudo dpkg --install panda3d1.8_1.8.1~squeeze_i386.deb

And saw this output:

Selecting previously unselected package panda3d1.8.
(Reading database ... 147260 files and directories currently installed.)
Unpacking panda3d1.8 (from panda3d1.8_1.8.1~squeeze_i386.deb) ...
dpkg: dependency problems prevent configuration of panda3d1.8:
 panda3d1.8 depends on libavcodec52 (>= 4:0.5.1-1) | libavcodec-extra-52 (>= 4:0.5.1-1); however:
  Package libavcodec52 is not installed.
  Package libavcodec-extra-52 is not installed.
 panda3d1.8 depends on libavformat52 (>= 4:0.5.1-1) | libavformat-extra-52 (>= 4:0.5.1-1); however:
  Package libavformat52 is not installed.
  Package libavformat-extra-52 is not installed.
 panda3d1.8 depends on libavutil49 (>= 4:0.5.1-1) | libavutil-extra-49 (>= 4:0.5.1-1); however:
  Package libavutil49 is not installed.
  Package libavutil-extra-49 is not installed.
 panda3d1.8 depends on libcv2.1; however:
  Package libcv2.1 is not installed.
 panda3d1.8 depends on libcvaux2.1; however:
  Package libcvaux2.1 is not installed.
 panda3d1.8 depends on libhighgui2.1; however:
  Package libhighgui2.1 is not installed.
 panda3d1.8 depends on libjpeg62 (>= 6b1); however:
  Package libjpeg62 is not installed.
 panda3d1.8 depends on libosmesa6 (>= 6.5.2-1); however:
dpkg: error processing panda3d1.8 (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for shared-mime-info ...
Errors were encountered while processing:

Also I’ve tried to run a sample program and saw this error:

Traceback (most recent call last):
  File "", line 13, in <module>
    import direct.directbase.DirectStart
ImportError: No module named direct.directbase.DirectStart

What have gone wrong?

Hi. :slight_smile:

Looking at the output of the installation command (the second piece of text that you quoted, I believe), it looks as though it provides the answer: there are a number of dependencies that are not installed on your system. Have you attempted to install any of them?

I’ve tried

sudo apt-get install libavcodec52

but got:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libavcodec52 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libavcodec52' has no installation candidate

It is clear that these libs are not in the Debian standard repository. But I don’t know how to get them.

Can you enable more repository components in your distribution’s software repository settings?

Yes, a can edit the sources.list

You can’t use the build for Debian Squeeze with your Debian Wheezy. You’ll have to compile it on your own, or I can roll out a build for you (I made a build for 64bit in the past, but unfortunately none for 32bit) if you want.

I have cheated and installed Ubuntu 12.04 instead. Maybe in future I will build Panda3D from source but not today. Now I want to learn some basics of this engine and try to write some simple games.

Then have fun with Panda3D! :slight_smile:

Hello, could I have a copy of the 64bit wheezy version? Or how can I compile it myself? Thanks