Installation Experience

Hi All,

Have finally taken the leap of faith and decided to try this game engine out.

I know people are providing help out of the goodness of their hearts, and we all appreciate it so please do not take this as a criticism, but just as maybe something that may be able to be improved.

I have done an install of a fresh download of the latest Pand3D package.
The machine had a virgin fresh install of WinXP pro (SP2). …my standard testing procedure for new software.


1)There is no MSVCR71.DLL file in existance under such and operating system configuration, and Pand3D also does not have one in its installation.

  1. Although there is scattered documentation about how to install a code editor, the Python files provided with the package already has “IDLE (Python GUI)” included.

I don’t know about the legalities of including MSVCR71.DLL within the panda3D installer, but if it could be included, that may save some new members a bit of a head ache. If it can not be included, then it may be advantages to document a how and where for the MSVCR71.DLL file if it is missing.

Also would it be possible to have the installer also add to within the Panda menu for the already installed “IDLE”.
This small addition may also save some new members some frustration to get things up and running in the early stages when they are still not fully familiar with what is going on.

I have currently just dropped a MSVCR71.DLL file within the “Python” root folder, and dropped a shortcut on to my desktop for the “Python\Lib\idlelib\idle.pyw” IDLE, having it set for open with “pythonw”, and everything is working very nicely.

I would also like to thank every one for the many interesting posts I have already read, I am learning a lot.

Regards sydbod :slight_smile:

Holy moly - I had no idea we were missing a DLL! This bug must have been in there absolutely forever… I imagine that most people probably have a copy of MSVCR71 laying around in their path somewhere, which is why nobody’s noticed that it’s missing until now. I will definitely fix this in Panda3D 1.5.3, which is coming out fairly soon.

I’m also surprised to learn that python comes with an editor - if thats what IDLE is? I had no idea. I will indeed provide a link to it.

Hi Josh Yelon,

I believe it is the Python engine for Windows that requires “MSVCR71.DLL”, and not Panda3D itself.

I never noticed this myself until I did a clean install onto a virgin machine, to check for any possible problems.
I did this to make sure I could help some novice friends as I would like to get them to play with this engine to make a simple multiplayer flight sim.

You will also find “IDLE” to be a relatively competent IDE in its own right. I also only realised it existed when I tried a virgin install of the latest Python package by itself. I had to see if the language made sense to me before I looked at Panda3d as it will be the first time I am playing with Python.

Thank you for your efforts in making this package as user friendly as possible. :slight_smile:

I have got WinXP SP2, and I have never encountered missing dll error. I also don’t have in Panda directory.
On the other hand, it’s true that my separate Python installations (2.4 and 2.5) do have MSVCR71.DLL in their folders.
I also have it in C:\WINDOWS\system32. As far as I know, this is completely enough to have the dll in this folder, and all programs that require it will work.

Hmm, I also noticed I had to add a copy of this dll manually when shipping my game, to make it work on clean systems. So, it would be indeed good if it gets added to Panda3D by default.

I just installed Panda3D on a clean Windows Server 2008, and this missing dll actually causes the installer to barf when attempting to install the “egg” files.

It’s mid October 2010. This is still not fixed?

It should be fixed by now. I’m surprised that you’re still seeing the same issue.

I too took the Panda Plunge and installed it on my older computer, with Pype, and have been having a blast ever since. I actually went and bought a better computer to do this with and after install any attempt to run a tutorial file gives me

“The program can’t start because MSVCR71.dll is missing. Try reinstalling the program to fix the problem.”

I don’t know why it works on my other computer and not this one. I bought the computer yesterday and downloaded Panda 1.6.2 just a few weeks ago.

Incidentally, Pype also refuses to run giving me a whole list of errors which ends with “ImportError: MemoryLoadLibrary failed loading wx_core_.pyd”

Being a dumb noob I have no idea if these are related or what to do about it. Searching for answers has lead me here.


-Brother B

Try installing Panda3D 1.7.0 instead of 1.6.2.


I fixed my problems by adding msvcp71.dll to my C:\windows\SysWOW64 folder and msvcr71.dll to C:\windows\Panda3D-1.6.2\python folder. Note to Noobs, these are two different dlls. If this is the correct way of fixing it, woohoo, noobs like me rejoice. If not, I will soon find out the hard way.

Either way, Panda3D is worth every moment.

-Brother B