Importing a collada file?

I’m new user of Panda3D…I’m sorry if this question was asked before but how do I import a dae model?
I first tried the usual code:


when it didn’t work I tried to use dae2egg.exe file found in bin folder
using command prompt I wrote

dae2egg.exe -o model.dae model.egg

and of course I specify the model path and then try to load the model with format .egg but it also didn’t work…What is the wrong thing did I do??
Thank you in advance

What exactly didn’t work when directly loading the .dae file?

Also, you wrote the command wrong. The correct command is:

dae2egg.exe -o model.egg model.dae 

thanks for replying…When I wrote the command (the correct one) and then write the code for importing the model on egg format, the game starts but no model although no error was found.
I use PyPE 2.8.8 for python and the message when loading the game was

DirectStart: Starting the game.
Known pipe types:
(all display modules loaded.)

I don’t know what to do

Did you reparent the model to render?

Also, try calling analyze() on the model to make sure it has geometry.

Yes of course

I downloaded it from 3d warehouse which models made by google sketchup…BTW,How to use analyse?? is by writing analyze(“model”)?
and do I have to import any library in my programe to make analyze function work??
Thank you

if you loaded model by model = loader.loadModel(), you can use


if you downloaded the model from 3d warehouse then the result is normal.
3d warehouse meshes are often created with sketchup that invert the value transparency ( so opaque value became totally transparent and are not shown in panda.)

For meshes created with 3d warehouse I had to change them before importing them:

change all the value " < float> 0.0"
with " 1.0"

done…but no change and the problem still

Well, edit the egg file with a text editor, spot a couple of blend*** tags, remove them. Does that work?

I didn’t find blend!!!
BTW…I tried pview and it works then I tried it again by positiong the camera as in the example in manual I saw the model on the screen. but a small problem is that I tried to import another in dae format it didn’t appear on screen and then I tried to use pview with it it didn’t work also then I tried using dae2egg.exe and the model was converted but with notes:

daeegg<Warning> no uv set binding found for input set 0
daeegg<Warning> no uv set binding found for input set 0
daeegg<Warning> no uv set binding found for input set 0
daeegg<Warning> no uv set binding found for input set 0
daeegg<Warning> no uv set binding found for input set 0
daeegg<Warning> unsupported entity type found

and also the egg format didn’t work…what is meant by that??

Please send .dae files that don’t work to my e-mail address and I’ll look what’s wrong with the exporter.

Also, note that Panda 1.6.2 has some bugs fixed in the .dae exporter - so if you’re not using 1.6.2, please upgrade first.

I’ve just received your model - thanks.

Your model shows up fine for me. I think it’s just positioned oddly, because pressing C in pview and then L makes it appear fine.

I got the trick and it works…Thank you very much for helping me
but when putting this model in my game it don’t appear, is there a default position values to put the model in the centre of the screen (for this or other models)??

Well, look how it’s positioned in the modeling program.
I recommend to position it around the origin in the modeling program.