ImportError: DLL load failed (fresh install)


on a fresh install of Panda3D 1.6., I get the following trace when trying to run sample programs. Any hint?

Best regards.

C:\Panda3D-1.6.2\samples\Fireflies>C:\Panda3D-1.6.2\python\python.exe -E
DirectStart: Starting the game.
Traceback (most recent call last):
  File "", line 6, in <module>
    import direct.directbase.DirectStart
  File "C:\Panda3D-1.6.2\direct\directbase\", line 3, in <module>
    from direct.showbase import ShowBase
  File "C:\Panda3D-1.6.2\direct\showbase\", line 10, in <module>
    from pandac.PandaModules import *
  File "C:\Panda3D-1.6.2\pandac\", line 2, in <module>
    from libpandaModules import *
  File "C:\Panda3D-1.6.2\pandac\", line 2, in <module>
  File "C:\Panda3D-1.6.2\pandac\", line 73, in Dtool_PreloadDLL
    imp.load_dynamic(module, pathname)
ImportError: DLL load failed

You should remove the “-E” option from the python command-line.

I just tried it, but the resulting stack trace is exactly the same.

Moreover, this command line is taken verbatim from the default shortcuts installed in the Windows Start Menu.

Is there anything I should setup manually after a Windows install? Some path setting perhaps so that the DLLs are properly found?


OK, I installed the .NET 3.5 SP1 framework, which fixed the problem.

Sorry for having not properly serched the forum before posting.

Dare I suggest that the Windows installer for Panda 3D should emit a warning if the .NET framework is not detected on a system?


Hello everybody
I don’t know if I have to open a new thread or not but I have the same problem
I’m using Windows XP Professional SP3 with .NetFramework 3.5 installed but the same error
I don’t know what to do

Well, I solved the problem by installing .NetFrameWork 3.5 SP1 not SP2 as previous
I think you must alert the users in the installation page about that
thanks a lot