I keep getting an error after installation

I have tried to install ver. 1.1.0 using the installer for windows on a Windows 98 SE and a Windows ME computer and the same thing seems to happen.
When I try to use the greeting card or any of the tutorials, the python prompt says:
DirectStart: Starting the game.
Warning: DirectNotify: category ‘Interval’ already exists

The windows error message details are:

PYTHON caused an exception 10H in module LIBDTOOLCONFIG.DLL at 017f:00d8501b.
EAX=03323c00 CS=017f EIP=00d8501b EFLGS=00010202
EBX=00000001 SS=0187 ESP=0071f208 EBP=0071f228
ECX=1019cd6c DS=0187 ESI=03323cb8 FS=3927
EDX=00000001 ES=0187 EDI=0071f27c GS=0000
Bytes at CS:EIP:
dd 5e 28 66 8b 57 30 66 89 56 30 4b 83 c6 38 c6
Stack dump:
03323ca0 03323cb8 03323cb8 03323cb8 0071f208 0071f2b4 00d91dd1 ffffffff 03323c78 00d8946e 03323cb8 03323cb8 0071f27c 03323ca0 0071f27c 03323ca0

Is there anything I can do to make them work?

Hmmm… did you try a re-download and re-installation? How does the older 1.0.5 work?

Regards, Bigfoot29

Err… edit: The Win9x-Problem… I thought the Panda3D-Guys fixed that?
TBH: I never got Panda3D working on Win9x but the devs said that they fixed that… couldn’t confirm it because I upgraded to Win2k…

I haven’t ever tested panda on win9x/winME. I don’t think I have a win9x/winME CD any more.

If you have a original key I can provide a ISO :wink: - from the original CD of course…

Regards, Bigfoot29

Doesn’t make a difference, the legal operator is “or”, not “and” - legal key + illegal copy = illegal use…

Ok… withdrawing that with the ISO :slight_smile:

Regards, Bigfoot29

If you donate the CD, I donate the shipping! :slight_smile:

I know that panda works on win9x. The toontown guys work hard to make sure that everybody can run their game.

However, I’m not sure that my distribution of panda works on win9x. We’d have to test it.

Yea… that was the problem a long time ago already in case you do remember… But as said, I couldn’t verify it because I switched to Win2k because Panda was not running (and I was able to get a Win2k-Licence for nuts)

It was a .dll problem, that some of the games have nowadays that are compiled on Win2k or XP…

Regards, Bigfoot29

I have uninstalled and installed ver. 1.0.5 and the greeting card seems to work normally (I’ve never seen it without any warnings or errors, so I don’t know if its running perfectly or not…). It doesn’t quit out to a windows error but the same python warning and a few new ones show up:

DirectStart: Starting the game.
Warning: DirectNotify: category ‘Interval’ already exists
Known pipe types:
(3 aux display modules not yet loaded.)
:display:windisplay(warning): SetForegroundWindow() failed!
:express(warning): Adjusting global clock’s real time by -53.017 seconds.

I’ve tried a few of the tutorials and they seem to be running according to their descriptions, but the python window always says the above. Should I not worry about the above and just use the older version? If so, do I have to use an older version of python to be able to use it?

Ah… well, that sounds like a win :slight_smile:

Nice. If the tuts are working, the other things will do at 99%

With the warnings I want to quote a (not very famous) actor:

Never seen the “setForegroundWindow” one, but the others are always visible.

Regards, Bigfoot29

Hm. I wonder what changed between 1.0.5 and 1.1.0? It is a new version of python - I wonder if that matters?

Not to the folks that prefer hand-compiled versions anyway! :wink: