I can't compile(mandriva 2010)

I’ve compiled ppremake and dtool (ppremake command line instruction don’t work, I must write all path , /usr/local/panda/bin/ppremake) but in panda dir using make instruction I got this error (and others derivated of this)
En el fichero incluído de config_gles2gsg.cxx:16:
gles2gsg.h:44:23: error: GLES2/gl2.h: No existe el fichero o el directorio
gles2gsg.h:45:26: error: GLES2/gl2ext.h: No existe el fichero o el directorio

the only reference of GLES/gl… found in google was in khronos.org , but downloading this files don’t work…

It sounds like you’ve got some configuration issues with ppremake–it’s detected that you have OpenGL ES installed, when you do not. ppremake does require a lot of by-hand configuration steps.

Have you tried to compile with makepanda instead? This is a more automatic tool that is more likely to run out of the box.


makepanda freezes at 21% (in task manager the children threads appears with 0% cpu)

How can I install OpenGL ES , in the site I could’nt find this…

That sounds like trouble. Have you tried running makepanda with --verbose?

Better plan is to configure ppremake to tell it you don’t have this. Add:

#define HAVE_GLES
#define HAVE_GLES2

to your personal Config.pp file.


this time works(with verbose opt), but first I give realtime priority to thread (risky but works)

some command to test if install correctly?

I test pkg-config --list-all|grep panda in console without results, or this command don’t show panda?

I don’t know–does it run?

Panda3D doesn’t ship with pkg-config files.

so how?

Did you invoke makepanda with the --installer option? If so, you should be able to find an .rpm in the source directory - you can install that.

so makepanda don’t install panda3d? LOL…

No, makepanda just builds Panda3D and can generate an installer. There’s also an installpanda script that installs Panda3D directly, but I recommend just letting makepanda generate an .rpm.

so now… how can I test Panda without start programming?

Try running the “pview” command. If Panda was installed correctly, it should show up a grey window with a blue triangle.

After that you could try running the sample programs.

Roger. Understood XD