I cannot pip install panda3d (Python 3.12.0)

I am a hobbyist who enjoys programming. I have installed the latest Python 3.12.0. I ran “pip install panda3d” from the command line as usual, but it failed to install with an error. I tried on Windows 10 and MacOS Ventura, but both failed to install.

PS C:\Users\user_name\Documents\solar_system> pip install panda3d
ERROR: Could not find a version that satisfies the requirement panda3d (from versions: none)
ERROR: No matching distribution found for panda3d

Please let me know as I am writing an article on Panda3D for a magazine.

  1. What is the reason why I cannot install it? Is it a problem on the pip side or is it because of Panda3D?
  2. Do you have any plans to fix this problem? If you can meet the publication date of the magazine (end of November or end of January next year), we can remove the statement “3.12 could not be installed”.

Thank you in advance.

There are no bindings for this python version, only 3.11

1 Like

Thank you for your response. I will include it in the article as such.

3.12 support is actively being worked on (mostly just testing and looking for bugs at this point) and will be part of the 1.10.14 release. I do not know when 1.10.14 will be released other then probably sometime within the next few months.

1 Like

Thanks for the detailed report, looking forward to 1.10.14.

Cool that you’re writing an article about Panda3D!

I’ve finished making experimental builds for Python 3.12, if you’re willing to try them out, just grab a link to the whl for your platform (and tagged “cp312”) and feed it to pip install:

1 Like

Thank you for the information. I was able to pip install on Windows 10 (64-bit). I would like to report that the my program worked without any problems. I hope that 1.10.14 will be released as soon as possible.