How to use baked ambient occlusion with blender 3.6 and panda3d-gltf?

I’ve been having issues importing my models with a baked AO map. I’ve set up the material nodes in blender as outlined here under “Baked Ambient Occlusion” glTF 2.0 — Blender Manual , and exporting from blender as .glb and .gltf and then loading with panda3d-gltf, but only the base colour shows in the areas of the model only subject to ambient light. I’m using simplepbr with use_occlusion_maps = True but I experience the same problem when only using the default viewer settings. Is there some setting that I need to change to show the AO shadows?

Finally fixed this- turns out the problem was that I wasn’t providing maps for metallic/roughness, just flat values, whereas simplepbr/gltf-viewer only like a combined map of occlusion/metallic/roughness.

1 Like