how do i....?

i have created a simple map using a simple plane with blender. I texturized it and added “empty” on the plane for where my character should start. start_point… and exported it to .egg… now my problem is, my model started where i wanted it to start but the problem is, it didn’t move walk nor run on my created map… what seems to be the problem? please help… I’m new to this… thanks :frowning:

Did you use the Roaming Ralph example as the foundation for your code?
If so, check and see if you added a collide field to the model of the map.

yes in fact i did use the roaming ralph as the foundation of my code… Sir, how do i see if i added a collide field?

i’ve edited my simple map using notepad++, and saw this:

==================================
{ Polyset keep descend }
Cube {
0 {
28.3540744781 28.3540744781 0.182706236839
{
0.000000 0.000000
{ 0.000000 0.999999 -0.001658 }
{ -0.999999 0.000000 0.000000 }
}

=================================

is this what you meant?
actually my map is just a simple plane with an added grassy texture…
and i’ve tried to use ralph as my model… basically, my map appeared, and so is ralph… but ralph couldn’t walk on the plane…

Yes, you have the collide field.
I’m not sure what else would be happening. Check to make sure your spawn position is not flush with the ground? I do know that the code for Roaming Ralph has a part that states that if Ralph is not in contact with anything, to keep him still/set him back to previous position. Try uncommenting the line that says

#self.cTrav.showCollisions(render)

In an unmodified Roaming Ralph file, this is on line 151. That puts it at the end of the function init(), so it should be easy to find.
This will show collisions so you can see if there are any occurring.

ok so from the simple plane that i used, i will have to place the start_pos option in contact with the plane for ralph to able to run? now if the “start_pos” option is not in contact with the plane, ralph wont be able to run? am i correct?

i’ve checked the “#self.cTraverser.showCollisions(render)” and uncommented the line… still ralph is running on its place not on the plane…

well thanks though… i’ll try things out… :frowning:

Yes, Ralph should just barely be in contact with the plane. You should be able to see triangles lit up on the map if Ralph is in contact.