Help with Intel graphics card


#1

Hi,
I have a laptop with an Intel x3100 integrated graphics card and am dual-booting between Ubuntu 9.10 and Windows. I have Panda installed in both operating systems, but the Ubuntu one doesn’t work correctly.

When I launch any of the tutorial applications I get the basic gray Panda window (and no error messages) but never see any graphics. The output seems identical to just a single-line run() application.

I have the latest drivers installed (2.9.x), all my desktop effects turned off, and have tried running using tinygl instead of the default which causes flat-out crashes. Any other ideas? I’m more comfortable programming with Linux tools and would love to get this working.

P.S. I’m sure it’s related to my graphics card because I’ve gotten it working flawlessly on other Linux machines.


#2

Which version of Ubuntu are you using? I’ve heard there were big problems with the Intel drivers on various versions of Ubuntu.


#3

I’m using the newest version – 9.10


#4

You may wish to try ubuntu 9.04 instead or a smaller linux altogether. I had very good lck with both of those (ubuntu 9.04 and Wolvix 2.0) on a three year old cheapee Aspire with intel on board graphix.

But ubuntu 9.1 was not rumored to be very friendly with the smaller low end laptops so I did not upgrade to it. Also expanding your system memory helps tremendously.

JB


#5

if you want a more recource friendly linux, i recommend xubuntu. it runs fine on my now 8 year old laptop. if that’s to heavy, go for puppy linux. and if thats still too mouch. take DmnSmallLinux .


#6

Thanks for the advice. When my university courses aren’t keeping me too busy I’ll try a lighter linux distribution, unless somebody else comes up with an idea.


#7

puppy is a nice setup and fast but it can have some wireless network issues with certain cards (as does Ubuntu) but it will definitely give you more free ram.

JB


#8

Hi!

I had the same problem. I fix it adding follow line in /etc/Config.prc:
vertex-buffers #f


#9

I can confirm the fix on ubuntu karmic, 64bits, Intel graphic card. Such a relief, thank you so much !


#10

Same here on Ubuntu 9.10 x86_64, Intel mobile graphics.

I had no error messages and nothing insightful from notify-level-glgsg debug. glxgears worked fine. All the samples would show a static grey or black window and do nothing.

The above fix worked great, thanks :slight_smile:


#11

Hi,

I was encountering the same “empty windows and no error message” problem on my HP Compaq 6730b Notebook (Intel GPU) running Ubuntu 9.10-64bits.

I confirm that the addition of “vertex-buffers #f” in /etc/Config.prc solved the issue for me too.

Many thanks to dlucio!!!

Cheers,


#12

Hi there! I have the same “empty windows and no error message” problem on my Dell Inspiron N7110 32 bits. I have tried some suggestions i was given at other forums, but in vain.


#13

Have you tried the suggestions in this thread, too?


#14

is there a solution to this?