Help with converting lwo to egg

Hello everybody.

I’m a new Panda user, so please forgive my trivial questioning.
I was in good spririts because Panda seems to have so much potential. (and a very good answer to my needs)
But it seems I have allready stumbled on the first hurdle.

I can’t seem to get my lightwave (lwo) files converted. (maybe my frustration is getting the better of my reasoning, and maybe I’ve overlooked the obvious solution all together)
I’ve been using command lines like:

lwo2egg.exe vessel.egg vessel.lwo
lwo2egg.exe -a model -o vessel.egg vessel.lwo
(not or half knowing what the “-a model” and “-o” stand for)

Nothing seems to work and the info I’m reading in the Manual isn’t very helpfull.

I’ve tried importing the model as lwo in a simple program, but it just won’t run with the lwo in it.
I hope it is not to much to ask: But how do I need to do this?
The convesion that is. I have my models(single layer, triangled) and I have lwo2egg.exe
Now what?

Any help would be much appreciated.

Perhaps the biggest piece you are missing is:

lwo2egg -h

which gives a summary of the options you can provide to lwo2egg. In particular, you should do:

lwo2egg.exe -o vessel.egg vessel.lwo

to convert vessel.lwo to vessel.egg (the -o stands for “output”, and refers to the next filename–it means in this case that “vessel.egg” is to be taken as the output filename for the conversion). Note that lwo2egg does not support the -a option, since lightwave objects don’t store animation.

You should be able to load a .lwo model directly into a program, with something like:

v = loader.loadModel('vessel.lwo')

You should also be able to preview a .lwo model directly with the command:

pview vessel.lwo


Thanks for the quick reply David.

I checked out the help on the program, and it says it can only work with lightwave 6 files, and “maybe” even with lightwave 5. Now, I exported the file as a lightwave 5 file. But lwo2egg was unable to open or read the file.

Thus I downloaded the X exporter for lightwave and take my chances with the x format.
However, it was giving the same error as the one I just mentioned. x2egg is unable to open and read the file.
“cannot read binairy x file at this time”

So i changed the file type to “text” instead of “binairy” and it converted the file flawlessly!
I saw it in the preview!
A step in the right direcetion. Thanks again!