Hello World Tutorial Problem

I just started with Panda3D and wanted to start with the Hello World example. When I add the animated Panda actor it shows up and animates but the texture for it does not appear. I just have a white, animated shape of a panda marching around the screen. I am running Panda3D using DirectX 9.0c. Anyone have any suggesting on what may be causing this?

Did the GreetingCard work correct?
Maybe there is a path not set correct

The Greeting card did not work either. Had the same issue. The animations/models showed up but there we no texture to them. What kind of path problem would I be looking for. The “actor” path is right because it is showing up. Is the texture for it not contained in the 3D model the actor is assigned?

Did you modify the /etc/Config.prc.
There must be a texture-path
Normaly its

texture-path .
texture-path $THIS_PRC_DIR/..
texture-path $THIS_PRC_DIR../models


Try running ppython from the console window. Look for error messages about not being able to find or load textures. If you see any, they will give us a clue.

If you don’t see these error messages, it may be a driver bug. Do you have an NVidia card? Try editing your Config.prc file, and change the line from:

load-display pandagl


load-display pandadx8

If this fixes it, you need to update your driver (or you can continue to run in DirectX mode). There was a version of the NVidia driver released a year or two ago that had a serious bug: it wouldn’t load textures in OpenGL mode.


OK, I fixed it. Here is what I did:

  1. Downloaded the latest driver for me video card and installed it. When I did this it was still not working.

  2. I switched panda to use OpenGL instead of DirextX 8.

This fixed it. I am speculating (without doing more research) that my video card driver does not support DirectX 8.

After I typed the above solution I remembered that you could force Panda to use DirectX 7. When I did this the textures worked fine. So, in the end the problem was that my video card driver does not support DirectX 8 or higher. (Not surprised…This is a 5 year old Dell laptop.)