Gltf exported animations not playing

Hey again!
I exported a model with animations from Blender (NLA Track checked) as a .gltf. The animation plays normally in the gltf viewer, but not in Panda3d. Even object.getAnimNames() is empty…
I use simplepbr.

Any help is welcome!

You may be trying to export an object animation, but it is not supported at the moment.

I’m not sure if I understand. Does ‘object animation’ refer to a specific type of animation or is it generally not possible to have animated gltf models in Panda3d?

Ok, I think I understand. In Panda3d, only object deformations are considered animations right? So how would I move a static object along a trajectory?

with motion paths. Ok, I got it now

You can use the hack by using one bone and applying the skin modifier to a mesh with a weight of 1, then just animate the bone.

Is there a more detailed explanation somewhere? Sorry, I’m super new to animation in blender and don’t really know what you mean.

Do I still export the bone animations from blender as gltf?

Or maybe more general: I want an animation in panda3d in which an object moves along a path while facing in the direction of movement. How do I do this using Blender and Panda3D?

Extra Points: More complicated animations involving mesh deformations

This type of panda animation is supported, it is named shape keys

The idea with the bone is simple, you create a skin modifier for the object and bind all the vertices rigidly to a single bone, then animate the movement of this bone.

You have an object exported as a character, only instead of a full-fledged skeleton, there is one bone for the entire object.

For reference, this method does not change the origin of the model, since it is an offset relative to the origin, that is, a pseudo-object animation. But I can definitely say that panda is able to use object animation, it needs to be implemented on the exporter’s side, and at the moment there is no such exporter in the official toolkit, but technically it is quite feasible.

Ok, so I animated a single bone in Blender and parented my mesh to it (also in Blender) and exported everything as gltf. While object.getAnimNames returns now [“Animation”], nothing happens when I play that animation. What went wrong/did I not understand?

I don’t quite get the skin modifier part. If I apply the skin modifier to my mesh it just creates some chaotic envelop around the mesh and I can’t choose weights. What’s the idea here?

Does it have to be exported as egg?

Ok, I finally figured it out after tedious trial and error. The thread below was very helpful

This .egg exporter add-on worked for me in Blender 3.41

If others have the same issue, I just drop some screenshots of the whole setup here that worked out in the end. Not everything might be necessary, but I’m too tired of this to deduce what mattered and what not.
Cheers! :slight_smile:


I will say: Unless things have changed with that exporter, please don’t use PRPEE; if you want to use a YABEE-variant, I suggest trying Maxwell’s version.

See this thread for more.

I see, thanks!

1 Like

I have a similar problem. I am tinkering with a free asset pack and the character model comes with animations. Windows it’s 3d viewer lets me see them and play them.

But the animations dont seem to be present in Panda3D. Am I doing something wrong? Is this the not supported animation type perhaps? I’ve tried opening it in blender 2.79 and exporting it using YABEE but had no luck.
character-skate-boy.glb (167.0 KB)

I think you need to check if your animation is based on an object or not. In other words, does it correspond to the declared list.

The main problem is that panda historically does not support object animations.

1 Like