GLSL shader compile errpr

#version 330
#extension GL_EXT_geometry_shader4: enable
#extension GL_EXT_gpu_shader4: enable

layout(triangle) in;
layout(points,max_vertices=1024) out;

uniform int uLevel;
uniform float uGravity; // <0 is down
uniform float uT;
uniform float uVelScale;
in vec2 p3d_MultiTexCoord0;
in vec4 p3d_Color;


Failed to parse extension directive at line 2 of file shadow/share/shaders/glsl/baoza.vert:
#extension GL_EXT_geometry_shader4: enable
:task(error): Exception occurred in PythonTask eventManager

I think you are missing a space, it should be

#extension GL_EXT_geometry_shader4 : enable

Huh, I could have sworn the spaces were non-optional to begin with. Anyway, just checked in a fix to Panda to no longer require those spaces around the colon.