full screen with packp3d? files .mf ?

Hi all

I have the following problems, I hope you help me please:

1- I have a main.py file and a “models” folder , inside main.py I have the following code:
loadPrcFile (“miConfig.prc”), which tells my game starts in fullscreen fullscreen # t, also, the default file Config.prc Panda3D it is configured with fullscreen # t. If I run my game from the windows console, the game opens in full screen, but if I create a file using packp3d the game (mygame.p3d) does not open in full screen. How do I get a file with extension p3d open in full screen?

  1. I have a main.py file and a folder called ‘models’ within the models folder have a file models.mf (mounted VirtualFileSystem). If I run my game from windows console all is well, but if I create a p3d file (mygame.p3d) this does not work, does not run, only weighs 14 kb. It seems that the command packp3d not recognize files .mf .
    As I pack a game (with files .mf) using packp3d ?

thanks for your help!

  1. I don’t have a solution for this, I fear, but want to report that I’ve been experiencing similar behaviour myself, if I’m not much mistaken (and posted regarding it, for that matter, although I’m afraid that I didn’t keep up with that thread): once compiled into a p3d file, certain lines in my prc files seem to be ignored (screen size and fullscreen mode are two that I’ve noted), while others seem be respected (such as setting whether the window may be resized). This behaviour doesn’t seem to be limited to my own computer.

  2. I believe that packp3d doesn’t by default include multifiles; however, you should be able to instuct it to additionally include files of specified extensions using the -n and -e flags to packp3d–the former specifies an uncompressible file type, while the latter specifies a compressible file type.

While I’m not sure that I’m correct in this, I believe that I’ve packed multifiles as uncompressible files.

To give an example:

packp3d -o appName.p3d -d someDirectory/anotherDirectory -n mf

@Thaumaturge Thank you very much for your time and help!
As for my first problem (open my game in full screen), I think it is because when you create the file .p3d this message “no such file p3d_info.xml” is displayed, this is the file indicating that the file config.prc be loaded. How I can get the p3d_info.xml file?

As for my second problem , I use the command -n mf, but the problem persists, it seems packp3d it does not recognize multifiles. Any other solution for this problem?

I used version 1.81

Thanks!

It’s my pleasure. :slight_smile:

As to “p3d_info.xml”, I’m honestly not sure. Looking at the manual, and given its presence in my own p3d files, I suspect that the file is automatically created by packp3d; if so, then it’s odd that might not be appearing for you. However, if it is being generated, having looked at the help for packp3d (by running packp3d with nothing but the “-h” switch), the “-c” switch might be helpful. To quote the help:

The manual gives a variety of config settings, but the one that seems likely of interest to us is “prc_name”, which apparently specifies a directory name from which to load custom prc files.

I haven’t yet tried this myself, however–if you do try it, please post to indicate whether or not it works!

As to “mf” files, would you please post the command line that you’re using for packp3d? The “-n” switch should work–I’ve used it myself, as I recall–so it may be that something is going wrong when you’re creating the p3d file.

Alternatively, have you opened up the p3d file and examined its contents? It may be that the file is being packed away, but that something else is now going wrong. In order to examine the contents of the p3d file (which is itself, if I recall correctly, more or less just a multifile), go to a terminal/cmd window, navigate to the location of your p3d file, and use the command "multify -tf "–for example, if your p3d file is “myGame.p3d”, then the command might be “multify -tf myGame.p3d”. Note that the “f” should be at the end of that list of switches (i.e., not before the “t”), since it takes the next thing after the “f” as the name of the file to open.

Examining the contents of your p3d file may also be useful in checking that your “p3d_info.xml” is in fact not being produced.