FC5 rpm on FC4 *weirdo* issue

i’ve tried (whistling and assuming a innocent expression) to install onto my FC4 the 1.2.1 FC5 rpm and this is what I got:

error: Failed dependencies:
   libcrypto.so.6 is needed by panda3d-1.2.1-1.i386
   libssl.so.6 is needed by panda3d-1.2.1-1.i386

I know that i can chisel it quieting those messages but I’m just curious:

  1. why Panda needs those libraries?
  2. Is it safe to ignore those dependancies???

These libraries are part of OpenSSL, which Panda uses to handle some optional features, such as encryption. It is possible to build a version of Panda that does not depend on OpenSSL (and does not provide these optional features), but the version that is pre-built and available on this site has this dependency compiled in.


Last time I tried to install FC4, it didn’t install correctly. I’ll try it again. If I can get it to install, I’ll release an FC4 RPM.

  • Josh

me too but I’ve managed it - try to tellme what issue you are experiencing so maybe I could be of one help

I uploaded a fedora core 4 RPM this morning. I haven’t tested it, let me know if it works.

  • Josh

the installation process has gone smooth like silk
* a note to everybody passing from 1.1.0 to 1.2.1: remember to rpm --erase the 1.1.0 before install the new one!
by the way, testing the samples I’ve found a little bug in

$ /usr/share/panda3d/samples/Feature-Tutorials–Render-To-Texture

Traceback (most recent call last):
  File "Tut-Render-To-Texture.py", line 115, in ?
  File "Tut-Render-To-Texture.py", line 47, in __init__
  File "/usr/src/redhat/BUILD/panda3d-1.2.1/BUILDROOT/usr/share/panda3d/direct/src/showbase/ShowBase.py", line 852, in makeCamera
AttributeError: 'NoneType' object has no attribute 'makeDisplayRegion'

Happy to see that the old bugs in various tutorials though have been all wipped off!

keep it up the great work!!!