Exporting model from Maya 2016 gives transparent model


After creating a model in Maya and exporting to egg format, this is what I get:

Why is the top of the model transparent?

This is what it looks like in wireframe mode:

I retextured and still got the same problem. Any help?

By the looks of it, I think that the polygons of your model are facing backwards. As a result, back-face culling is removing the polygons that you expect to be facing towards you, and leaving the ones that you expect to be facing away from you, giving the impression of a transparent -front and -top.

In Maya, look for an option to turn on back-face culling; if I’m right, doing so should result in Maya showing the model much is you’re seeing it shown in Panda.

As to fixing it, I don’t use Maya myself (I use Blender), so I’m somewhat guessing at how Maya might approach these matters. You might look for an option to reverse or flip the model’s normals (a model’s normals are associated with the orientations of its polygons).