Exporting from Maya 2009 on a Mac


I’m a new Panda3D user working with a Mac (Leopard 10.5.7) and the latest version of Panda3D (1.6.2). I’ve been building 3D models in Maya and I would like to use a Python-based game engine to add some interactivity.

Unfortunately, it looks like the current maya2egg commands are designed for Maya 2008. I’ve got Maya 2009, which means I can’t seem to export using maya2egg or the MayaPandaTool.mel. In fact, when I load the MayaPandaTool in Maya’s Script Editor, or drag it into the working area, Maya shuts down entirely. There doesn’t seem to be a maya2egg2009 command for Macs, and I can’t use maya2egg2008 since I don’t have Maya 2008 installed on my system.

Is there a way to get around this issue and successfully export my models? I’m looking into other game engines that might fit my requirements, but I’d like to use Panda if possible.

Thanks very much for your time. I can provide more information if you need it.

You have a couple of choices:

  • Build Panda yourself, from source code, against the Maya 2009 SDK.
  • Give me the Maya 2009 header files and libraries and let me do it for you.
  • Use ColladaMaya to export it to .dae, and use dae2egg.

Thank you very much for your reply! I’ve made some progress with the dae2egg method you suggested, but I’m not quite there yet. The shapes in Panda just don’t match up with what I see in Maya. For example, take a look at these screenshots. The UV texture doesn’t appear in Panda, although the .egg file contains a texture reference, and it appears to be correct. The cube isn’t white, so there must be something there, but it’s not the image I want.

Here is the cube in Maya:

Here is the same cube loaded into Panda3D:

You’ll notice that the shape looks distorted as well, although that might be a separate issue altogether. If it helps, when I run dae2egg -o uvsquare.egg uvsquare.dae, my command line tells me:

Reading uvsquare.dae
:daeegg(warning): No uv set binding found for input set 0
Writing uvsquare.egg

So the .egg file can write successfully, but something is wrong with the textures. I’m out of ideas, so please let me know if any solutions spring to mind. I can provide more information if you need it: the code I’m using, steps I took to make my UV map in Maya, etc.

Otherwise I will take a stab at building the program against Maya, although I’ll admit at this point I’m kind of afraid to try it. Maybe I’ll send you those libraries after all.

Please send me the .dae file in question (including any textures) so I can debug the converter.

It would be great if you could send me the libraries, then other users will be able to benefit from it, too!
I’m going to need the .dylib and .a files directly under the /Applications/Autodesk/maya2009/Maya.app/Contents/MacOS directory excluding libfbxfilesdk.*, and I also need the devkit/include/maya/ directory.

That would be very helpful! I’ve sent along those files to your email.

hello I had the same issues with maya2009 as the user describes above (crashes when I try to import MayaPandaTool.mel and cant get any of the maya2egg converters to work with my version of maya). I tried the dae2egg approach but now get the following error with this:

$ dae2egg --h
dyld: Symbol not found: __ZN12EggPrimitive11r_transformERK9LMatrix4dS2_16CoordinateSystem
Referenced from: /Applications/Panda3D/1.6.2/bin/dae2egg
Expected in: /usr/local/panda/lib/libpandaegg.dylib

dae2egg image7_23_09.dae image7_23_09.egg
dyld: Symbol not found: __ZN12EggPrimitive11r_transformERK9LMatrix4dS2_16CoordinateSystem
Referenced from: /Applications/Panda3D/1.6.2/bin/dae2egg
Expected in: /usr/local/panda/lib/libpandaegg.dylib

Trace/BPT trap

^C^XTrace/BPT trap
Ekstrom-iMac:towns adekstrom$ dae2egg ucdavis7_23_09.dae ucdavis7_23_09.egg
dyld: Symbol not found: __ZN12EggPrimitive11r_transformERK9LMatrix4dS2_16CoordinateSystem
Referenced from: /Applications/Panda3D/1.6.2/bin/dae2egg
Expected in: /usr/local/panda/lib/libpandaegg.dylib

Thank you in advance for your help. Until I can convert to egg, I can’t do much with Panda. Any other tips for maya to egg converters for OX X would be very helpful. Thanks again.


Hmm, do you maybe have multiple versions of Panda that are conflicting with each other?

i’ve installed 1.6.2 and that is the only version in my applications directory.



how would I find out if I have other “hidden” versions?



I am still having trouble converting maya2009 files into egg files…the maya2egg2009 program on my mac OS X 10.5.7 machine is seg faulting. is this likely to be a problem with the trial version of maya2009? or is there something else i should be trying? going the dae2egg route doesnt seem to work very well as it doesnt convert all of the features i see in maya (as charrell eludes to above). is there another route that users go to get egg files from maya? any help would, as always, be greatly appreciated.


Yes, I’m also still having trouble making .egg files. (The maya2egg2009 gives me an error message, which pro-rsoft and I have been trying to sort out over email.) If anyone else has some ideas for Maya 2009 conversion on a Mac, please let me know.