Exporting an animation to .egg with YABEE in Blender 2.83.4

I am working on a basic rigging/animation for proof of concept. I was able to follow a tutorial to parent armatures to a mesh and animate changes in the pose. This works and animates correctly in Blender. However, when I use YABEE to export, I run into an error:

Unexpected error during export! See console for traceback.

When I look at the console in Blender it is completely blank. There is no info to troubleshoot.

I tried a couple of things to narrow the problem down, and it seems the problem comes from animating my blend. The armature/mesh appear to export fine if there is no animation, but once I add the animation there are issues with exporting.

I am using YABEE 14.9 (https://github.com/kergalym/YABEE) and Blender 2.83.4

If anyone could give some advice I would greatly appreciate it.

YABEE does not support Blender 2.8x. I recommend using blend2bam instead.

This new version of YABEE is intended for Blender 2.8, but I will give blend2bam a try.