Error starting Panda 1.2.3 and 1.1.0 on Windows 2003


I’m trying to run Panda on a Windows Server 2003 R2 with Direct X 9c installed but when i try to run any of the demos i get the following error. Both panda 1.2.3 and 1.1.0 give the same error.

C:\Documents and Settings\Loki\Start Menu\Programs\Panda3D 1.2.3\Basic Tutorials
\Lesson 1 Solar System>DirectStart: Starting the game.
Traceback (most recent call last):
  File "", line 11, in ?
    import direct.directbase.DirectStart
  File "D:\usr\Panda3D\direct\src\directbase\", line 3, in ?
    from direct.showbase import ShowBase
  File "D:\usr\Panda3D\direct\src\showbase\", line 6, in ?
    from pandac.PandaModules import *
  File "D:\usr\Panda3D\pandac\", line 2, in ?
    from libpandaModules import *
  File "D:\usr\Panda3D\pandac\", line 1, in ?
    from libpanda import *
ImportError: DLL load failed: Invalid access to memory location.

My video card is an ATI MOBILITY RADEON X600.
If there’s anything else you need to know please let me know.
I’d be grateful if someone could offer a solution soon :slight_smile:


Panda 1.0.5 installs and works correctly, it doesn’t produce the error above.

This is pretty mysterious. It may be a mismatch between some other DLL’s you already have installed. Have you uninstalled all other versions of Panda?

How about pview? Does pview work properly?


What’s pview ? Is this it ?

I didn’t have panda installed before trying 1.2.3. I unstalled each version before trying to install the other one. I finally ended up with 1.0.5 that worked.
I suspect it’s something in panda3d that’s creating the problem, maybe an entry point to a dll function that’s not pointing correctly.

No, that’s something different. pview.exe is a standalone program that ships with Panda. It doesn’t use Python, but it does use the Panda dll’s to open a graphics window, and it can be used to view egg files and bam files.

It may certainly be a problem completely within Panda3d; but the thing is, Panda3d appears to runs fine on other people’s systems. So it must be that there is something unique about your system that is confusing Panda3d.

In the past, we have had problems where people had a different version of some dll installed elsewhere; for instance, a different version of zlib.dll, which appeared first on the path and caused problems with Panda. I was under the impression that most of these problems have been eliminated by renaming Panda’s version to, for instance, panda_zlib.dll, but there may be some obscure possible problems remaining. In particular, having different versions of Panda installed can conceivably cause this problem (because in that case, you have multiple files named panda_zlib.dll), which is why I asked about that; but of course, it is not the only possibility.


Sorry for taking this long to answer but i’ve been a bit busy. Since 1.0.5 worked for me i used that for my project and now that i’m done with it i could uninstall that version and install 1.2.3 again.

I’ve tried running pview.exe and it crashes too, saying “The application failed to initialize properly (0xC0000005). Click Ok to terminate the application”. IIRC “0xC0000005” is access violation error.
I’ve looked inside pview.exe with dependecy walker and it seems to have some links to .net libraries. Does Panda need .Net to run ? because I have only .Net 2 installed. It may very well be Windows linking dinamically to these libraries because no other candidates have been found. The dlls in question are COMCTRL32, GDIPLUS and WINHTTP (they may not be actual .Net libraries but they use the same way of avoiding Dll Hell - suggested by the path they’re stored in).
Also, i’ve seen that panda uses it’s local copy of MSVCR71.dll - just a note, i don’t think this causes the error (i only have MSVCR80.dll installed globally).

I’m curious, has anyone else been able to followup on this forum question?

We have a client who is also running our Panda3D 1.2.3-based application on Windows Server 2003. When he runs the application it fails with the exact same error message on his machine. His videocard is an ATI FireGL v3100 with 128MB RAM.

If anyone has any further insight on this issue, it would be most welcome. I’m going to fire up our copy of 2k3 in the morning and see what I can find.