Endless Tunnels

If you have a good GPU, check out my endless tunnels ray traced (kinda) demo (eventually to be mini game)

New download, run ray.py:
10 kb, not bad for almost being a game.

Countrols: WASD + Mouse (Q and E roll, arrow keys can be used instead of mouse). I recommend trying to fly around without hitting anything while holding down W the whole time.

The screen will turn solid red when you are inside something (you can move until you are not inside, or restart the game). You should now start in an opening. The tunnels are now pulsating for extra coolness.

All drawn to a single full screen quad in a shader at a fantastic 8.5 fps. Wow! I lowered the rez a bit in the release so it should run faster now. I’ll eventually do a low rez pass to speed things up.

(Old version and pic)

Old version download: just the ray.py file in my simplex noise project:
(Newer/smaller download is in the middle of post)

I just get colored stripes and: “Cg program too complex for driver: Ray.sha. Try chosing a differen profile.”
I have a Geforce 9400…

That means you need to put “basic-shaders-only #f” in your Config.prc file.

thx, now it “works” (no errors, 4.6 fps, staying black even with pressing W for 20 sec)

Black? Should be green or orange in that version. Must be that its not working right somehow. I’ll put the basic shaders setting in there, and fix the starting pos for my next release. Thanks for trying it!

I updated the main post with a new download, new picture and some updated descriptions. I messed up with the basic-shaders-only #f, oh well. I’ll fix that in the next release.

Edit: It should be all fixed now. Release updated. Please let me know if it work or now if you try it.

now I have much more fps but its only red for some sec and then black for some sec then again red, black, …

tried switching to pandadx9 but then i just get cg-error and colored stripes.

Hum, I suspect its shader instruction count fail. It seems that when shaders get too long, they can just cut out in the middle, in this case leaving black, or red. Your graphics card probably isn’t up to my monstrosity of a shader. It uses almost no graphics memory, just a massive fragment shader program (truly horribly massive).

When you get the stripes, thats just my noise data table texture, so seeing it means the shader failed to even compile properly.