end-user having trouble reinstalling to play Toontown

My sons had been playing disney’s toontown with no issue until today. totontown uses the panda engine. starting up the game results in an endless loop of installing whatever gets installed each time they play and the download. It seemed to be an issue related to panda, so i tried thru toontown to set-up a new account and download a new version of panda. when doing so, upon installation, i am told install can’t proceed because a newer version already exists on my computer. I have gone into every account on the computer and deleted anything i can find that i think relates to panda, but with no luck. then I came to the panda site and tried downloading the engine directly from here. same problem (newer version already exists). Running Mac OS 10.6.4. any help for a dad just trying to let his sons play toontown???

Toontown support may be able to offer some better advice here than we can; but I can offer some suggestions.

First, I wouldn’t worry too much about the “newer version” problem. It’s just telling you that you don’t need to install another copy of the Panda plugin, since you’ve already got one installed. If you really do want to uninstall the previous one, and force an installation from scratch, I think you can do it with the command:

sudo pkgutil --forget org.panda3d.pkg.runtime

But I really doubt that the version of the Panda plugin is related to your installation problem.

The actual content of the game is downloaded into ~/Library/Caches/Panda3D. If you delete this folder, it will force a clean download of the Toontown game, which should be much better behaved.

Still, I’m curious about the endless loop you were getting. That does sound like a potential bug in Panda3D. Can you tell me more about it?


I deleted every trace of P3D following your instructions and still cannot re-install/install P3D via Toontown because a newer version exists.

Are there any “hidden” files I/we should know about? Or maybe an update to for fixing this problem?


Keep in mind there are two different things to install:

(1) The Panda3D plugin. This is the only part that might complain about a newer version already existing. If it does complain, it just means that you already have it installed, and there’s no need to install a new one. This is good, because the operating system does make it difficult to reinstall this. It’s possible, though, if you’re really determined.

(2) The Toontown game. (Re)installing this has absolutely nothing to do with (Re)installing the Panda3D plugin, above. If you are having problems with the game, reinstalling the plugin probably won’t help you solve them, but reinstalling the game might, depending on the nature of the problem. Fortunately, it is easy to reinstall this part.

Now, as to what problem you are actually having, I can’t tell you whether it should be solved by reinstalling (1) or (2) without knowing more details about the problem. It’s quite likely that even if we successfully walked through the steps to reinstall (1), nothing at all would change and you would still have the same problem.

So, can you give me more information about the way in which Toontown is failing to load?


ok im having simalar issue i presume im on a mac as well toontown was working just fine yesterday and now im stuck on a “installing panda3d toontown rev 21”
version 10.4.11 and the installer or whatever shoots up to about 75% than goes back to begining and goes maybe 5% and doesnt go any further i have removed the panda add on earlier and didnt solve my problem i uninstalled toontown and reloaded and still same problem im at wits end of what the problem is i have looked in caches and no file that you told other guy exist in mine at all so what gives need help asap