When I try to use egg2maya2012, I get this error:
Win32 is not a valid application.

This happens when you use a 32-bit version of Panda with a 64-bit version of Maya, or vice-versa. Use a 64-bit version of Panda (only in development builds) to use a 64-bit version of Maya.

Could you send me a link to 1.8.1 64 bit? The installer on the website gave me 32 bit.

1.8.1 does not have a 64-bit build. You’ll have to download a development build, like: … =devel&sdk

Also, please don’t double-post, especially when you’re already being helped in another thread.

It says I don’t have maya2012 installed, but I do. Do I need to move the files somewhere?

What is the exact error message you are getting?

Maya 2012 is searched for in the following location in the registry:

If that doesn’t exist, you could try defining an environment variable called MAYA_LOCATION containing the path to Maya.

“Cannot locate MAYA2012: does not appear to be installed”
Where can I find the maya value? Can I set it to where maya is installed to on my computer?

If you’re running it from the command prompt you can set the path as follows:

set MAYA_LOCATION=C:\Path\To\Maya
maya2egg2012 your-args-here

Now it’s trying to find bin\OpenMaya.dll
but my Maya.exe thing is in bin. So it looks for bin\bin

Then instead of setting your MAYA_LOCATION to the “bin” directory, you should try setting it to its parent directory.

I have tried both with and without bin
It says maya2012 isnt installed.

Are those the only messages you’re getting? Please post the whole output.

Also, instead of MAYA_LOCATION, please try setting PANDA_MAYA_LOCATION. Not to “bin”, but to the parent directory of “bin”.

Here is output:

You forgot the = after PANDA_MAYA_LOCATION

Nothing happens.