egg texture stage problems : __FGLTexMgrAllocMem failed!!

i am having problems with loading textures for about 3 days now
this is what the debug out put looks like

i normaly could load hundreds of textures and every thing worked fine. The only thing that changed is bind a multi texture to a loaded egg file exported form max rather binding the 2 texture stages to the geom i make my self with Geom generators.

what could be cousing this problem?
are there any work around?
do i need any thing special to load teaxtures now?

this is what i get at the very end after the fglX11AllocateManagedSurface: __FGLTexMgrAllocMem failed!!


PS i also get this but i think that is related to the font textures

I’ve never seen that error message before, but it sure does seem like something’s screwy about the new texture you’re loading. Is there anything unusual about it?


i found when i avoid loader.loadCubeMap its works fine. I am thinking maybe i uses more texture ram then it says :slight_smile:

fglX11AllocateManagedSurface: __FGLTexMgrAllocMem failed!! -> means i run out of ram on the card i have 128MB.

the problem does not happen if i bind 2 texture stages to a node i create my self only when i bind 2 texture sages to a node i .find("**/hull") inside a model loaded from the eggfile. but if i avoid loader.loadCubeMap every thing works fine.

oh and i figured out what the Kimberley is. its an inturnal name of the font i am using. Why does it have to reload textures so often? i have lots of text that might have been the case too. But it cosed no problems doing it the other way.