Egg loader causes python to crash

greeting to the community.

i am facing a very annoying problem when trying to load a particular egg (15203510.zip). my python crashes with:

Process finished with exit code -1073741571 (0xC00000FD)

The egg file itself is fine, i was able to open it with pview. i found an old panda3d forum discussion here:

but the solution of setting the recursion limit with loadPrcFileData(’’, ‘egg-recursion-limit 3000’) does not have any effect. i tried lower and higher values but nothing happens.

the dll that crashes the program is libpandaegg.dll and i am sensing a possible bug. how is pview opening the file correctly? is there another way to load an egg maybe?

thanks for any help

Hmm, odd.

I downloaded your egg and found that I could successfully load it on my machine. Thus, presuming that there’s no relevant difference between our installations of Panda, I’m inclined to suspect that the issue might be arising either from some difference between our two systems (maybe you’re running out of memory?), or in the specifics of your program.

The latter is perhaps the easier to test: what happens if you attempt to load your model in a minimal program? Just something like this:

from direct.showbase.ShowBase import ShowBase

class Game(ShowBase):
    def __init__(self):
        ShowBase.__init__(self)

        self.disableMouse()

        self.accept("escape", base.userExit)

        self.model = loader.loadModel("15203510")
        # (I'm presuming that the model has that name on your end,
        # as in your zip-file.
        self.model.reparentTo(render)
        self.model.setPos(741.396, 500, -1483)

game = Game()
game.run()

Which version of Panda3D do you have?

i was using 1.10.5 and i switched to 1.10.6. both give the same result. i did not test with an older version.

hm, at least thats something. i will do this test.
regarding the memory i do not think this is the case. my code opens 300 of those files and the crash is at number 3, so it happens right at the beggining.

ok i did the test you have suggested and it still crashes. so i will ask which windows, python and panda3d versions are you using?

I’m using Ubuntu Linux (18.04.4, specifically), with Python version 3.6.9 and Panda 1.10.6 (1.10.6.post2, specficially), I believe.

I checked your file, Panda 1.10.6, Windows 10. Python, he just silently closed the console.

1 Like

oh no, you’re using linux. now that just made my day. i am using same python and panda3d version. so its a windows problem.
what i make from all this is that this is a bug of the egg reader but i cant debug it since its a dll. who developed this? who can i adress with this problem?

ok update on my problem. i was able to solve it. it seems that the problem is related to the egg format. i used an fbx format and it passes correctly. there is another problem though related to transparency but i will open a separate post for that. thanks to all

It might perhaps be worth opening an entry for this in Panda’s GitHub issue-list–that way it is, I think, more likely to be seen, remembered, and perhaps fixed by the engine devs.