[egg exporter] can't export animation

i wanted to export a small animation i made with blender like the tutorial, but i can’t.
This is the exporter in the tuto:

and this is my exporter(there is no option for animation):

Did you use the armature modifier to attach the armature to the object?
Did you select your object+armature before exporting?
Did you troubleshoot the Chicken manual about exporting animations?

Well, this is my .blend file so you can test you’re self(it 's a stupide animation, but it’s just for test :stuck_out_tongue: ).

(1) Go to object mode.
(2) Select the box.
(3) In the Modifiers tab, hit “Make Real”.

Then, it shows up for me in the exporter.

i tested that with this settings:

but i have always the same problem

After doing above steps to the above .blend file, and selecting all objects, the “Add Animation” button appeared in the exporter.

i did all the steps you have mentionned, but i couldn’t add any animation to my model. This the new .blend file: http://maroxe.olympe-network.com/animation.blend

Now you removed the modifier. Select the Cube, hit Add Modifier, Armature, and for “Ob:” type “Armature” (which is the name of your armature). Do not press Apply.
Then if I load up the Chicken exporter, the “Add Animation” button appears.

PS. Keep in mind that Chicken does not export envelopes correctly.

it works now, thanks :smiley:
but why do i have not to press apply?

oh sorry, i did not read this completely , now know there is many ways to get animation…

Very nice thread, solved my problems instantly :slight_smile:

Hi guys,

i wanted to export my animation with 3 different meshes(hair, body and clothes), but there is only export the animation an the body.

I selected all of the objects, when I exported! I set shadeless.