Disable Vertical Blank

Anyone knows how to disable the “Vertical Blank” as it’s called sometimes? Usually when programs don’t have it enabled, you see this nasty crack in the on screen graphics. It happens because part of the last buffer is still showing when a new buffer gets drawn. Enabling “Vertical Blank” will ensure that the screen gets an entire update from a new buffer without showing part of the last.

Panda3D has this enabled by default. Does anyone know how to disable this effect?

The manual says that it’s disabled by default (if I got the point, that should be the sync-video option).

sync-video #f

put in your Config.prc

Uhm, #t stands for true, which means it is enabled by default.


I have another question and I figured I’ll post it here instead of creating a bunch of Topics.

I’ve notice I get a speed increase in some areas of this program I’m working on when I have texture-compress to true.

If my program is depended on texture-compression, then what does that mean? Do I have too many textures or are they too large?

I use mostly JPEG images, which is a compressed format to begin with. I do use some PNGs for transparency.

Most of my textures are 64x64, 128x128, 256x256, 512x512. I might have several 1024x1024 and a couple…maybe one 2048x2048…not sure about the 2048.

I’ve tried converting the JPEGs 16 million colors to 256 bit colors. Doesn’t work well because the images would just go back to 16 million color bits once saved.

I’m trying to avoid using the texture-compression because it might not be support on other Machines.

I think it’s the fact textures are TOO BIG.

When I changed the textures sizes to 0.5,

texture-scale 0.5

I got the same speed increase without using texture-compression.

I guess Panda3D works best with textures being no bigger than 256 because you can’t exclusively set the Antialiasing (or how ever it’s spelled)to a reasonable value…you’re only setting a Minimum to Multisample and this feature is expensive when set to Max. For me that’s x16 AA that can’t be changed!!!

A Multisample fix would be nice for Panda Version 7. I saw the Bio for the Gentleman working on Panda’s Engine. Can’t remember his name, but he has a PHD in Computer Science.

Lol, my sentence was misleading. I was referring to blinking (because he was talking about blinking), which shouldn’t appear because (by default) sync is true.