DirectX not found ?


after successfully building my panda debug and release version I noticed something :

the makepanda could not find any directX SDK and therefore added --no-dx8 and --no-dx9 to my command line.

I have got the June 2010 DirectX SDK installed on my computer (available from here

anyone knows why that is ?


Sure, you need to modify in order to change the reference to the correct SDK version.

Here is the modified file I’m using:

For whatever reason SDK versions are kept as old ones in the official panda release…

I’ve finally come around to test this - and it does something now but still it doesn’t compile.

I am running Windows 7 Home Premium (64 bit), DirectX June 2010 SDK and I’ve tried to compile panda with the following command :

C:\Panda3D\panda3d>makepanda\makepanda.bat --everything --no-python --no-ode --v
erbose --optimize 1 --outputdir PandaDebug

it fails while looking for a ddraw.lib which isn’t installed on my system ( I believe newer directx don’t have direct draw support anymore).

Has anyone tested panda3d with directx on a windows 7 64 bit system ever ?

hi Chrys
Install Microsoft DirectX SDK (August 2009) and recompile Panda.
it worked for me, try it.

I’m positive, you can use latest DirectX June 2010 SDK on Windows 7 Home Premium (64 bit)
Have a look for instance at this post (bottom)
[url]compiling panda3d without python]