DirectX 7

When I try to use DirectX 7 I get this error message:

Can anyone tell me why I’m getting this message when it’s not supposed to be using OpenGL?

Probably because Panda no longer supports DirectX7, so it is probably printing an error message when loading pandadx7, and failing over to OpenGL instead.


I see. Well, here’s my problem. If I use DX9 I do get good performance, and I haven’t actually had any problems yet, but I do get this warning:

I don’t know what will happen, but I’m guessing this is a big problem. I tried turning on texture compression in the configuration file, but it did nothing.

If I use DX8, I get no warnings, but it runs a lot slower.

If I use OpenGL, it runs a lot slower than DX9 and I do get the warning posted above.

So, is there anything I can or should do about this, or are Panda and my laptop perhaps not a good match up?

This means that you are running far less than 64 MB of video RAM.

All in all I don’t see BIG problems but since 64 MB video ram are somewhat outdated (even some onboard chips normally allow 128+) it may be a solution to update to a video solution with the appropriate ammount of memory. (e.g allowing (by bios) more video ram to be used in/for IGPs)

On the other hand: Did you try using DX8 as well? (Can’t verify this since I am running Panda3D on Linux)

Regards, Bigfoot29

Hmm. Maybe I will look into getting my RAM upgraded.

Yes I did try it, and I didn’t get any warnings, but it ran at about half the frame rate.

hmmm… if that also increases the RAM on your video card… do you use an on board video chip or an separate video card?

If its the last one, you propably NEED a new graphic card. Otherwise setting more video ram in the bios may be enough (if enough memory for the rest of the system is available).

I would check that (both things) before buying new RAM. :slight_smile:

Regards, Bigfoot29

I use the video card that came with my system, if that’s what you’re asking.

How would I do that exactly?

Thanks for the replies, by the way.

if you are using the video that came with your system there is a good chance that you are using onboard, but there is also a good chance that you are not.

to enter the bios reboot your computer and hold down the delete key(it is probably the delete key, but maybe not).

if you end up at a bios screen, start looking around, you should be able to find where you adjust the amount of memory your graphics can use

sorry that i dont know the options name (but it may be different on another motherboard), but i use a full blown graphics card so i dont really need to fiddle with that stuff

ps: if it turns out you are using a graphics card, you REALLY need to update, if you are using onboard, you should be fine with some tweaking

Hmm, I found the bios menu, but what I think is what you were talking about was greyed out and I couldn’t get to it. :confused:

Well, maybe I shouldn’t be messing with this anyway, being that I really don’t know anything about it.