DirectEntry Attribute Error [SOLVED]

I was working on getting my saving and loading functions for my game and I ran into a problem with a DirectEntry object getting an attribute error.

Here’s a snippet of the error report:

File "C:\Panda3D-1.7.2\direct\gui\", line 271, in get
wantWide = self.unicodeText or self.guiItem.isWtext()
AttributeError: 'DirectEntry' object has no attribute 'guiItem'

I don’t know if this is a bug in the current panda build, or if my panda build is corrupted or something, but I know I want to fix it without reinstalling panda or waiting for an update. Since the file in question is a python file, I’m wondering if I can copy and paste the guiItem attribute from another DirectGUI component or some such.

This isn’t corrupted code, this is what happens when you access a DirectEntry (or any other DirectGui item) whose destroy() method has already been called. The guiItem member is the underlying implementation of the DirectEntry object, and it is normally cleaned up and removed on destroy().


I see, so the entry is being destroyed before the call to get. I’ll look into that, thank you.

Yeah, I found the early destroy call and removed it. Now it works fine. Makes me feel like an idiot, though.

Thanks, as always, for your assistance.