Daily Snapshots (Buildbot)

Maybe, but actually Panda is the only program folder I can not rely on :stuck_out_tongue: But you’re right, nevertheless usually you leave the folders untouched. But hey, once the samples folder is there why not put more samples in there?
Issue would be half as bad if the Panda folder wasn’t deleted but only moved to the trash. Logout is also kinda unusual, I only heard of that when people on newer MacBookPros want to activate or deactivate the graphics card. After the logout of the 1.7.0 installation the computer was a lot slower by the way, I did a restart then.

Error for Ball in Maze sample after replacing the line:

Does that mean one has to replace these lines everywhere? In all samples? In all files of one’s project? That’s quite a lot isn’t it? Shouldn’t there be a transitional period where both syntaxes work?

Another thing: How do you multiple versions of Panda3D, if the path is Developer/Panda3D/stuff instead of Developer/Panda3D/version/stuff ?

Thumbs up. I tested Panda3D-2010.01.12-18.dmg and the DYLD_LIBRARY_PATH hack is not necessary anymore. Thanks a lot.

At startup there is just a small thing that seems to have changed since previous versions:

:audio(error):   load_dso(libp3fmod_audio.so) failed, will use NullAudioManager
:audio(error):     dlopen(/Developer/Panda3D/lib/libp3fmod_audio.dylib, 10): Library not loaded: ./libfmodex.dylib
  Referenced from: /Developer/Panda3D/lib/libp3fmod_audio.dylib
  Reason: image not found

This does not prevent the my test program to run, but I didn’t have that error previously.

You don’t. That might change if we switch to using frameworks though.

@kaweh: Great! Thanks for testing. I see why the fmod error is occurring, the fix will make it into the next build;

EDIT: Try the 12-19 build.


Asteroids sample

Same error with my project it seems

No fmod error with 12-19 anymore. Thanks a lot!

Let me know if you need any more testing or if I can help with the samples.

Everything works? Awesome! Thanks for helping me out with testing.

@Bradamante: the buildbot is now running build 21 of the OSX SDK, when it’s ready, it should contain your fix.

Said it was compiling for like two hours, I was refreshing for quite some time.


everthing works again :smiley:

Hm the standard font type is new. Good to see my project live again.

i am getting two errors with the most recent panda3d build for ubuntu 9.10 64 bit:

$ pview
pview: error while loading shared libraries: libCg.so: cannot open shared object file: No such file or directory
$ python test.py 
Traceback (most recent call last):
  File "test.py", line 2, in <module>
    import util.logger
  File "/p/2awr/util/__init__.py", line 1, in <module>
    from pandac.PandaModules import *
  File "/usr/share/panda3d/pandac/PandaModules.py", line 8, in <module>
    from libpandaModules import *
  File "/usr/share/panda3d/pandac/libpandaModules.py", line 2, in <module>
  File "/usr/share/panda3d/pandac/extension_native_helpers.py", line 79, in Dtool_PreloadDLL
    imp.load_dynamic(module, pathname)
ImportError: libavformat.so.52: cannot open shared object file: No such file or directory

Yeah, sorry, the daily package doesn’t list dependencies. In this case, you’re missing the packages nvidia-cg-toolkit and ffmpeg.

Tried using egg2bam, got this error:


egg2bam /Applications/Mare\ Ceti/mcships/Neut_Glider_Menu/Neut_Glider_Menu.egg 
dyld: Library not loaded: libp3dtoolconfig.1.7.0.dylib
  Referenced from: /Developer/Tools/Panda3D/egg2bam
  Reason: image not found
Trace/BPT trap

In the docs for packp3d it references pack3d.p3d.

panda3d packp3d.p3d -o myapp.p3d -d c:/myapp

Where is this file located? Its not in program files\panda3d. I performed a complete search of my system as well and it was not found.

Get it at:

I’m in the process of splitting my windows box to create a Ubuntu partition. (driver issues have sabatoged any real development for me on windows for the time being.)

I was wondering if you have an i386 version of 1.7.0 for Karmic somewhere. The botbuild versions look like there’s only amd64 versions.

launchpad.net/~panda3d/+archive … ld/1467201

Any idea when the Windows nightly builds will be back in business?

I just added a i386 builder. Also, the ubuntu builds now come with Maya 2008 support.

As for the Windows builds, I’ll see if I can get a build machine set up somewhere, either virtual or physical.

You rock! :slight_smile:

The Windows buildbot is back into business! :slight_smile:

Bless you :smiley:


And I just fixed the weekly CHM builds of the manual as well. :slight_smile: