Crash when running yorg on Catalina

I ran and it did not crash. But when I run it does.

This is on 10.15 Catalina. I’ve added input monitoring permission in System Preferences.

There’s no backtrace, just this error:

illegal hardware instruction python3 -m pdb

I’m using pdb to find the line where it crashed:

> yorg/venv/lib/python3.7/site-packages/direct/showbase/
-> def run(self):
(Pdb) n
> yorg/venv/lib/python3.7/site-packages/direct/showbase/
-> if self.appRunner is None or self.appRunner.dummy or \
> yorg/venv/lib/python3.7/site-packages/direct/showbase/
zsh: illegal hardware instruction  python3 -m pdb

I hesitate to resurrect this thread 8 months later, but after carefully checking github/Moguri/cefpanda/issues/6 and github/panda3d/panda3d/issues/795, it seems yorg is not creating two NSApplication instances, just using direct.showbase.ShowBase like what’s on this thread, so maybe it is relevant?

I’ll keep poking around inside the yorg code base.

Hi, welcome to the community. I’ve moved your post to a new topic because it is unrelated to the topic you were posting in.

Could you show us the crash report that macOS gathers (or a gdb/lldb backtrace)?