Could not Open Window and Config file not working


#1

I just pip installed Panda3d 10 on Windows; I changed the Config file to use DirectX9, however the “could not open window” error I get with GL persists. I’ve tried all available configurations in the config file to no avail; the program I was using worked fine before now. Any help?

Known pipe types:
wglGraphicsPipe
(all display modules loaded.)
:display(error): The application requested harware acceleration, but your OpenGL
:display(error): driver, GDI Generic, only supports software rendering.
:display(error): You need to install a hardware-accelerated OpenGL driver, or,
:display(error): if you actually *want* to use a software renderer, then
:display(error): alter the hardware/software configuration in your Config.prc file.
:ShowBase(warning): Unable to open 'onscreen' window.
Traceback (most recent call last):
  File "DW_gameworld.py", line 65, in <module>
    app = World()
  File "DW_gameworld.py", line 15, in __init__
    ShowBase.__init__(self)
  File "C:\Users\Olivia\AppData\Local\Programs\Python\Python37-32\lib\site- 
  packages\direct\showbase\ShowBase.py", line 274, in __init__
    self.openDefaultWindow(startDirect = False, props=props)
  File "C:\Users\Olivia\AppData\Local\Programs\Python\Python37-32\lib\site- 
   packages\direct\showbase\ShowBase.py", line 940, in openDefaultWindow
    self.openMainWindow(*args, **kw)
  File "C:\Users\Olivia\AppData\Local\Programs\Python\Python37-32\lib\site- 
  packages\direct\showbase\ShowBase.py", line 976, in openMainWindow
    self.openWindow(*args, **kw)
  File "C:\Users\Olivia\AppData\Local\Programs\Python\Python37-32\lib\site- 
   packages\direct\showbase\ShowBase.py", line 725, in openWindow
    raise Exception('Could not open window.')
   Exception: Could not open window.

#2

Looks like Panda is still trying to load an OpenGL context. Maybe something is overriding your config (e.g., a load_prc_data() call in the source code)?

As for the OpenGL error, do you have up-to-date graphics drivers? What GPU are you using? I would expect to see an error like that if a proper GPU driver was not installed and the default Windows GPU drivers were being used.


#3

I’m mentioning this just in case, but make sure you don’t use the “PSPad” program to edit your Config.prc file. It irreparably corrupts files that are saved with a .prc extension.


#4

I’m running Windows 10 on a Windows 7 laptop, and device manger says my graphics drivers are up to date. The Driver Model is WDDM 1.2, and I’ve got Direct3D 11.1

And thanks! I used Notepad so I think I’m in the clear :wink:


#5

What is the GPU and where did you get the GPU driver? Is your application loading any PRC variables via code (e.g., via load_prc_file() or load_prc_file_data())?


#6

I’m not loading prc variables in the application; I have an intel Core i5 that the laptop’s always had. I’ve been looking through device manager, dxdiag and system settings looking for GPU but I definitely don’t know what I’m looking for. (Google won’t tell me where the GPU driver is, even though I feel it should be fairly obvious.) Here’s some screenshots in case I’m just being blind.


#7

Looks like OpenGL support for that GPU on Windows 10 is a mess, which is frustrating since Panda’s OpenGL backend is a lot better than its D3D backend. Anyways, let’s see if we can get D3D working for you.

Which config file are you editing, and what edits have you tried? You can also try putting this into an application prior to opening a window:

panda3d.core.load_prc_data('', 'load-display pandadx9')

#8

Putting this before the application in code:

import panda3d
panda3d.core.load_prc_data('', 'load-display pandadx9')

tells me that core has no attribute for load prc data; I’m just assuming I don’t have the correct import. So far the only config file I’ve edited is in Panda3d-1.10/etc. I’ve only done the normal comment/uncomment driver choices in there, so everything’s untouched so far.


#9

I think that’s supposed to be panda3d.core.load_prc_file_data, not load_prc_data.

…wow, searching around, Intel apparently really does not make Windows 10 drivers for your card, Intel HD Graphics 3000. That’s beyond unfortunate.

I’m kind of curious to see what would happen if you tried to install the Windows 8 drivers instead, from here:


#10

Wow, that is. Go figure I guess. The window works now that I’ve got the correct line of code before the app, so until I hit that ever-coming new laptop it’ll do. :wink:

Installing the Windows 8 drivers is piquing my curiosity… but at the moment I’m not interested in going through the hassle of getting my current drivers back if something somewhere goes awry. If I get impatient I’ll post back here with how it went, but thanks so much both of you! I really appreciate it.