Could not launch maya2egg2008-wrapped.exe

I have Panda 1.6.2 installed on windows-xp (32bit) and Maya 2008.
Any time I try to convert an mb file to egg via command line, such as:

maya2egg2008 -o myEgg.egg myMb.mb

I get “Could not launch maya2egg2008-wrapped.exe.” I’ve been trying to fix this problem for three days with no luck. I’ve read all the forum posts I could find, this one being the most relevant (although it doesn’t seem to contain a solution):

It doesn’t seem to matter what is in the Maya model - a sphere, cube, plane… nothing seems to work. I have no other versions of Maya or Panda installed.

Can anyone help?


maya2egg2008.exe is actually a stub program that sets up several environment variables necessary to run Maya correctly, and then launches maya2egg2008-wrapped.exe, which does the actual work.

What error message do you get if you attempt to run maya2egg2008-wrapped directly?


The system cannot execute the specified program.

Oh, hey, we just ran into this exact problem. It turns out to be solved by installing the proper set of manifests into the Windows system directory.

The only way we’ve found so far to get the proper set of manifests is to install a version of Microsoft Visual Studio 2005 or above, which (among many other things) copies the appropriate files into the system directory. (Installing service packs and whatnot doesn’t seem to be sufficient.)

Is this an option for you?


My modeler is trying to do all the exporting, but he doesn’t have access to visual studio.
Do you have any suggestions?

Microsoft provides a free “express edition” of Visual Studio which anyone can download and install:


OK, great. Does it matter which version he installs (VB, C++, Web Developer)?

I don’t know. We installed the C++ version, and that worked for us.


Good, that’s what I told him to install.
Thanks, I’ll let you know if it works…

Thanks David. Installing C++ express edition did the trick!

Glad to hear it! I’m sorry it’s such a terrible hack, though. Maybe someone will be able to figure out a better workaround someday. :confused:

My hope is that this is just a temporary problem with the current version of Maya, and it will go away when Autodesk releases the next version of Maya. It hasn’t worked that way yet, though.


about next version of maya,…

did the 1.7.0 will have a maya2egg2010 ?